gnu: looking-glass-client: Adjust for Mesa 19.2.
[jackhill/guix/guix.git] / gnu / packages / mastodon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mastodon)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system python)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (gnu packages check)
25 #:use-module (gnu packages python-web)
26 #:use-module (gnu packages python-xyz)
27 )
28
29 (define-public toot
30 (package
31 (name "toot")
32 (version "0.21.0")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (pypi-uri "toot" version))
37 (sha256
38 (base32
39 "1dqv5jckaw3r7dnfns3iygwbfnf27x513qrw2rryzl5y79xrzs1x"))))
40 (build-system python-build-system)
41 (arguments
42 '(#:phases
43 (modify-phases %standard-phases
44 (delete 'check)
45 ;; see https://github.com/ihabunek/toot/issues/91
46 (add-after 'unpack 'dont-install-Makefile
47 (lambda _
48 (substitute* "setup.py"
49 (("data_files.*" all) ""))
50 #t))
51 (add-after 'install 'check
52 (lambda* (#:key inputs outputs #:allow-other-keys)
53 (add-installed-pythonpath inputs outputs)
54 (invoke "py.test"))))))
55 (native-inputs
56 `(("python-pytest" ,python-pytest)))
57 (propagated-inputs
58 `(("python-beautifulsoup4" ,python-beautifulsoup4)
59 ("python-requests" ,python-requests)
60 ("python-wcwidth" ,python-wcwidth)))
61 (home-page "https://github.com/ihabunek/toot/")
62 (synopsis "Mastodon CLI client")
63 (description "Interact with Mastodon social network from the command line.
64 Features include:
65 @itemize
66 @item Posting, replying, deleting statuses
67 @item Support for media uploads, spoiler text, sensitive content
68 @item Search by account or hash tag
69 @item Following, muting and blocking accounts
70 @item Simple switching between authenticated in Mastodon accounts
71 @end itemize")
72 (license license:gpl3)))