gnu: Add AVR-Libc.
[jackhill/guix/guix.git] / gnu / packages / yasm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages yasm)
20 #:use-module (gnu packages)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages python)
26 #:use-module (gnu packages xml))
27
28 (define-public yasm
29 (package
30 (name "yasm")
31 (version "1.2.0")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "http://www.tortall.net/projects/yasm/releases/yasm-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "0cfg7ji3ia2in628w42wrfvw2ixmmm4rghwmv2k202mraysgm3vn"))))
40 (build-system gnu-build-system)
41 (inputs
42 `(("python" ,python-wrapper)
43 ("xmlto" ,xmlto)))
44 (home-page "http://yasm.tortall.net/")
45 (synopsis "Rewrite of the NASM assembler")
46 (description
47 "Yasm is a complete rewrite of the NASM assembler.
48
49 Yasm currently supports the x86 and AMD64 instruction sets, accepts NASM
50 and GAS assembler syntaxes, outputs binary, ELF32, ELF64, 32 and 64-bit
51 Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
52 debugging information in STABS, DWARF 2, and CodeView 8 formats.")
53 (license (license:bsd-style "file://COPYING"
54 "See COPYING in the distribution."))))