gnu: Add itpp.
[jackhill/guix/guix.git] / gnu / packages / wget.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages wget)
22 #:use-module (guix licenses)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages libidn)
25 #:use-module (gnu packages python)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages web)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages tls)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public wget
35 (package
36 (name "wget")
37 (version "1.19.1")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnu/wget/wget-"
42 version ".tar.xz"))
43 (patches (search-patches "wget-CVE-2017-6508.patch"))
44 (sha256
45 (base32
46 "1ljcfhbkdsd0zjfm520rbl1ai62fc34i7c45sfj244l8f6b0p58c"))))
47 (build-system gnu-build-system)
48 (inputs
49 `(("gnutls" ,gnutls)
50 ("libidn2" ,libidn2)
51 ("libpsl" ,libpsl)))
52 (native-inputs
53 `(("pkg-config" ,pkg-config)
54 ("perl" ,perl)
55 ("python" ,python) ;for testenv suite
56 ("perl-http-daemon" ,perl-http-daemon)
57 ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
58 (home-page "https://www.gnu.org/software/wget/")
59 (synopsis "Non-interactive command-line utility for downloading files")
60 (description
61 "GNU Wget is a non-interactive tool for fetching files using the HTTP,
62 HTTPS and FTP protocols. It can resume interrupted downloads, use file name
63 wild cards, supports proxies and cookies, and it can convert absolute links
64 in downloaded documents to relative links.")
65 (license gpl3+))) ; some files are under GPLv2+
66
67 (define-public wgetpaste
68 (package
69 (name "wgetpaste")
70 (version "2.28")
71 (source
72 (origin
73 (method url-fetch)
74 (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
75 version ".tar.bz2"))
76 (sha256
77 (base32
78 "1hh9svyypqcvdg5mjxyyfzpdzhylhf7s7xq5dzglnm4injx3i3ak"))))
79 (build-system gnu-build-system)
80 (arguments
81 '(#:phases
82 (modify-phases %standard-phases
83 (delete 'configure)
84 (delete 'build)
85 (replace 'install
86 (lambda* (#:key outputs #:allow-other-keys)
87 (let* ((out (assoc-ref outputs "out"))
88 (bin (string-append out "/bin"))
89 (zsh (string-append out "/share/zsh/site-functions")))
90 (install-file "wgetpaste" bin)
91 (install-file "_wgetpaste" zsh)))))
92 #:tests? #f)) ; no test target
93 (home-page "http://wgetpaste.zlin.dk/")
94 (synopsis "Script that automates pasting to a number of pastebin services")
95 (description
96 "@code{wgetpaste} is an extremely simple command-line interface to various
97 online pastebin services.")
98 (license public-domain)))