gnu: Add itpp.
[jackhill/guix/guix.git] / gnu / packages / iso-codes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages iso-codes)
21 #:use-module ((guix licenses) #:select (gpl2+))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages gettext)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages python))
28
29 (define-public iso-codes
30 (package
31 (name "iso-codes")
32 (version "3.67")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append
36 "https://pkg-isocodes.alioth.debian.org/downloads/iso-codes-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "037hmfs5pk3g36psm378vap1mbrkk86vv8wsdnv65mzbnph52gv0"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("gettext" ,gettext-minimal)
44 ("perl" ,perl)
45 ("python" ,python-wrapper)))
46 (home-page "https://pkg-isocodes.alioth.debian.org/")
47 (synopsis "Various ISO standards")
48 (description
49 "This package provides lists of various ISO standards (e.g. country,
50 language, language scripts, and currency names) in one place, rather
51 than repeated in many programs throughout the system.
52
53 Currently there are lists of languages and countries embedded in
54 several different programs, which leads to dozens of lists of
55 200 languages, translated into more than 30 languages... not
56 very efficient.
57
58 With this package, we create a single \"gettext domain\" for every
59 supported ISO standard which contains the translations of
60 that domain. It is easy for a programmer to re-use those
61 translations instead of maintaining their own translation
62 infrastructure. Moreover, the programmer does not need to follow
63 changes in the ISO standard and will not work with outdated
64 information.")
65 ; Some bits use the lgpl2
66 (license gpl2+)))