gnu: fet: Update to 5.45.0.
[jackhill/guix/guix.git] / gnu / packages / education.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
5 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
9 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages education)
27 #:use-module (ice-9 regex)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages audio)
30 #:use-module (gnu packages base)
31 #:use-module (gnu packages bash)
32 #:use-module (gnu packages compression)
33 #:use-module (gnu packages curl)
34 #:use-module (gnu packages databases)
35 #:use-module (gnu packages flex)
36 #:use-module (gnu packages fonts)
37 #:use-module (gnu packages freedesktop)
38 #:use-module (gnu packages game-development)
39 #:use-module (gnu packages gettext)
40 #:use-module (gnu packages glib)
41 #:use-module (gnu packages gnome)
42 #:use-module (gnu packages gtk)
43 #:use-module (gnu packages image)
44 #:use-module (gnu packages javascript)
45 #:use-module (gnu packages kde)
46 #:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
47 #:use-module (gnu packages mp3)
48 #:use-module (gnu packages ncurses)
49 #:use-module (gnu packages perl)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages python)
52 #:use-module (gnu packages python-web)
53 #:use-module (gnu packages python-xyz)
54 #:use-module (gnu packages qt)
55 #:use-module (gnu packages readline)
56 #:use-module (gnu packages sdl)
57 #:use-module (gnu packages sqlite)
58 #:use-module (gnu packages texinfo)
59 #:use-module (gnu packages tls)
60 #:use-module (gnu packages video)
61 #:use-module (gnu packages xorg)
62 #:use-module (gnu packages xml)
63 #:use-module ((guix licenses) #:prefix license:)
64 #:use-module (guix packages)
65 #:use-module (guix download)
66 #:use-module (guix git-download)
67 #:use-module (guix svn-download)
68 #:use-module (guix utils)
69 #:use-module (guix build-system cmake)
70 #:use-module (guix build-system gnu)
71 #:use-module (guix build-system python)
72 #:use-module (guix build-system qt)
73 #:use-module (guix build-system trivial)
74 #:use-module (srfi srfi-1))
75
76 (define-public gcompris
77 (package
78 (name "gcompris")
79 (version "17.05")
80 (source (origin
81 (method url-fetch)
82 (uri (string-append "http://gcompris.net/download/gtk/src/gcompris-"
83 version ".tar.bz2"))
84 (sha256
85 (base32
86 "18y483alb4r4vfmh80nnl0pah5gv0b8frcm6l1drb9njn5xlcpgc"))))
87 (build-system gnu-build-system)
88 (arguments
89 `(#:configure-flags
90 ;; Use SDL mixer because otherwise GCompris would need an old version
91 ;; of Gstreamer.
92 (list "--enable-sdlmixer"
93 "LDFLAGS=-lgmodule-2.0")
94 #:phases
95 (modify-phases %standard-phases
96 (add-after 'set-paths 'set-sdl-paths
97 (lambda* (#:key inputs #:allow-other-keys)
98 (setenv "CPATH"
99 (string-append (assoc-ref inputs "sdl-mixer")
100 "/include/SDL:"
101 (or (getenv "CPATH") "")))
102 #t)))))
103 (inputs
104 `(("gtk+" ,gtk+-2)
105 ("librsvg" ,librsvg)
106 ("libxml2" ,libxml2)
107 ("sdl-mixer" ,sdl-mixer)
108 ("sqlite" ,sqlite)
109 ("glib:bin" ,glib)
110 ("python" ,python)))
111 (native-inputs
112 `(("intltool" ,intltool)
113 ("texinfo" ,texinfo)
114 ("texi2html" ,texi2html)
115 ("glib:bin" ,glib "bin")
116 ("pkg-config" ,pkg-config)))
117 (home-page "https://gcompris.net")
118 (synopsis "Educational software suite")
119 (description "GCompris is an educational software suite comprising of
120 numerous activities for children aged 2 to 10. Some of the activities are
121 game orientated, but nonetheless still educational. Below you can find a list
122 of categories with some of the activities available in that category.
123
124 @enumerate
125 @item computer discovery: keyboard, mouse, different mouse gestures, ...
126 @item arithmetic: table memory, enumeration, double entry table, mirror image, ...
127 @item science: the canal lock, the water cycle, the submarine, electric simulation ...
128 @item geography: place the country on the map
129 @item games: chess, memory, connect 4, oware, sudoku ...
130 @item reading: reading practice
131 @item other: learn to tell time, puzzle of famous paintings, vector drawing, cartoon making, ...
132 @end enumerate
133 ")
134 (license license:gpl3+)))
135
136 (define-public gcompris-qt
137 (package
138 (name "gcompris-qt")
139 (version "0.98")
140 (source
141 (origin
142 (method url-fetch)
143 (uri (string-append
144 "https://gcompris.net/download/qt/src/gcompris-qt-"
145 version ".tar.xz"))
146 (sha256
147 (base32 "1jmjykn0lpk0v6hs2flmch8v4da5bgxl891nav7szxw9l7aqnf4y"))))
148 (build-system cmake-build-system)
149 (arguments
150 `(#:phases
151 (modify-phases %standard-phases
152 (add-after 'unpack 'disable-failing-test
153 (lambda _
154 (substitute* "tests/core/CMakeLists.txt"
155 (("DownloadManagerTest\\.cpp") "#"))
156 #t))
157 (add-before 'check 'start-xorg-server
158 (lambda* (#:key inputs #:allow-other-keys)
159 ;; The test suite requires a running X server.
160 (system (string-append (assoc-ref inputs "xorg-server")
161 "/bin/Xvfb :1 &"))
162 (setenv "DISPLAY" ":1")
163 #t))
164 (add-after 'install 'wrap-executable
165 (lambda* (#:key inputs outputs #:allow-other-keys)
166 (let ((out (assoc-ref outputs "out")))
167 (wrap-program (string-append out "/bin/gcompris-qt")
168 `("QT_PLUGIN_PATH" ":" prefix
169 ,(map (lambda (label)
170 (string-append (assoc-ref inputs label)
171 "/lib/qt5/plugins"))
172 '("qtbase" "qtdeclarative" "qtmultimedia" "qtsvg")))
173 `("QML2_IMPORT_PATH" ":" prefix
174 ,(map (lambda (label)
175 (string-append (assoc-ref inputs label)
176 "/lib/qt5/qml"))
177 '("qtdeclarative" "qtgraphicaleffects"
178 "qtmultimedia" "qtquickcontrols"))))
179 #t))))
180 #:configure-flags (list "-DQML_BOX2D_MODULE=disabled"
181 "-DBUILD_TESTING=TRUE")))
182 (native-inputs
183 `(("extra-cmake-modules" ,extra-cmake-modules)
184 ("gettext" ,gettext-minimal)
185 ("kdoctools" ,kdoctools)
186 ("perl" ,perl)
187 ("qttools" ,qttools)
188 ("xorg-server" ,xorg-server-for-tests)))
189 (inputs
190 `(("openssl" ,openssl)
191 ("python-2" ,python-2)
192 ("qtbase" ,qtbase)
193 ("qtdeclarative" ,qtdeclarative)
194 ("qtgraphicaleffects" ,qtgraphicaleffects)
195 ("qtmultimedia" ,qtmultimedia)
196 ("qtquickcontrols" ,qtquickcontrols)
197 ("qtsensors" ,qtsensors)
198 ("qtsvg" ,qtsvg)
199 ("qtxmlpatterns" ,qtxmlpatterns)))
200 (home-page "https://gcompris.net/index-en.html")
201 (synopsis "Educational games for small children")
202 (description
203 "Gcompris offers a large collection of educational games for small
204 children, designed to be a unified interface to integrate more educational
205 games. Language-oriented games contain vocabulary, sounds, and voices for
206 many different languages.
207 Currently available boards include:
208 @enumerate
209 @item learning how to use a mouse and keyboard
210 @item learning simple arithmetic
211 @item learning how to read an analog clock
212 @item recognize letters after hearing their names
213 @item reading practice
214 @item small games (memory games, jigsaw puzzles, ...)
215 @end enumerate\n")
216 (license license:gpl3+)))
217
218 (define-public tipp10
219 (package
220 (name "tipp10")
221 (version "2.1.0")
222 (source (origin
223 (method url-fetch)
224 ;; guix download is not able to handle the download links on the
225 ;; home-page, which use '<meta http-equiv="refresh" …>'
226 (uri (string-append "mirror://debian/pool/main/"
227 "t/tipp10/tipp10_2.1.0.orig.tar.gz"))
228 (sha256
229 (base32
230 "0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
231 (patches (search-patches "tipp10-fix-compiling.patch"
232 "tipp10-remove-license-code.patch"))))
233 (build-system cmake-build-system)
234 (arguments
235 `(#:tests? #f ; packages has no tests
236 #:phases
237 (modify-phases %standard-phases
238 (add-after 'unpack 'disable-new-version-check
239 (lambda _
240 ;; Make new version check to default to false.
241 ;; TODO: Remove the checkbox from the dialog and the check itself
242 (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
243 (("settings.value(\"check_new_version\", true)")
244 "settings.value(\"check_new_version\", false)"))
245 #t))
246 (replace 'configure
247 (lambda* (#:key outputs #:allow-other-keys)
248 (let ((out (assoc-ref outputs "out")))
249 ;; Make program honor $PREFIX
250 (substitute* "tipp10.pro"
251 (("\\.path = /usr/") (string-append ".path = " out "/")))
252 (substitute* "def/defines.h"
253 (("\"/usr/") (string-append "\"" out "/")))
254 ;; Recreate Makefile
255 (invoke "qmake")))))))
256 (inputs
257 `(("qt4" ,qt-4)
258 ("sqlite" ,sqlite)))
259 (home-page "https://www.tipp10.com/")
260 (synopsis "Touch typing tutor")
261 (description "Tipp10 is a touch typing tutor. The ingenious thing about
262 the software is its intelligence feature: characters that are mistyped are
263 repeated more frequently. Beginners will find their way around right away so
264 they can start practicing without a hitch.
265
266 Useful support functions and an extensive progress tracker, topical lessons
267 and the ability to create your own practice lessons make learning to type
268 easy.")
269 (license license:gpl2)))
270
271 (define-public snap
272 (package
273 (name "snap")
274 (version "5.4.5")
275 (source
276 (origin
277 (method git-fetch)
278 (uri (git-reference
279 (url "https://github.com/jmoenig/Snap.git")
280 (commit (string-append "v" version))))
281 (file-name (git-file-name name version))
282 (sha256
283 (base32 "1z6dbcsgvxxs40p23qysfsk4vzpg8jlrr5pqfnjf8q3kpz1xvzxf"))))
284 (build-system trivial-build-system)
285 (arguments
286 `(#:modules ((guix build utils))
287 #:builder
288 (begin
289 (use-modules (guix build utils))
290 (let* ((source (assoc-ref %build-inputs "source"))
291 (out (assoc-ref %outputs "out"))
292 (share (string-append out "/share/snap")))
293 (copy-recursively source share)
294 ;; Replace the sole minified file in the package.
295 (with-directory-excursion (string-append share "/src")
296 (delete-file "FileSaver.min.js")
297 (symlink (string-append (assoc-ref %build-inputs "js-filesaver")
298 "/share/javascript/FileSaver.min.js")
299 "FileSaver.min.js"))
300 ;; Create a "snap" executable.
301 (let* ((bin (string-append out "/bin"))
302 (script (string-append bin "/snap"))
303 (snap (string-append share "/snap.html"))
304 (bash (string-append (assoc-ref %build-inputs "bash")
305 "/bin/sh"))
306 (xdg-open (string-append (assoc-ref %build-inputs "xdg-utils")
307 "/bin/xdg-open")))
308 (mkdir-p bin)
309 (call-with-output-file script
310 (lambda (port)
311 (format port "#!~a\n~a '~a'" bash xdg-open snap)))
312 (chmod script #o555)))
313 #t)))
314 (inputs
315 `(("bash" ,bash-minimal)
316 ("js-filesaver" ,js-filesaver)
317 ("xdg-utils" ,xdg-utils)))
318 (home-page "https://snap.berkeley.edu")
319 (synopsis "Visual, blocks based programming language")
320 (description "Snap! (formerly BYOB) is a visual, drag-and-drop
321 programming language. It is an extended reimplementation of Scratch (a
322 project of the Lifelong Kindergarten Group at the MIT Media Lab) that
323 allows you to Build Your Own Blocks. It also features first class
324 lists, first class procedures, and continuations. These added
325 capabilities make it suitable for a serious introduction to computer
326 science for high school or college students.
327
328 This package provides a @command{snap} executable calling @command{xdg-open}
329 to open the application in a web browser, for offline usage.")
330 (license license:agpl3+)))
331
332 (define-public toutenclic
333 (package
334 (name "toutenclic")
335 (version "7.00")
336 (source
337 (origin
338 (method url-fetch)
339 (uri (string-append "http://www.bipede.fr/downloads/logiciels/"
340 "ToutEnClic-" version "-src.zip"))
341 (sha256
342 (base32 "0xg24p925rl5bfqsq3jb2lrkidb0f3kbmay5iyxxmjsn3ra0blyh"))))
343 (build-system python-build-system)
344 (arguments
345 `(#:tests? #f ; no tests
346 #:phases
347 (modify-phases %standard-phases
348 (delete 'build)
349 (replace 'install
350 (lambda* (#:key outputs #:allow-other-keys)
351 (let* ((out (assoc-ref outputs "out"))
352 (share (string-append out "/share/toutenclic"))
353 (pixmaps (string-append out "/share/pixmaps"))
354 (doc (string-append out "share/doc/" ,name "-" ,version))
355 (bin (string-append out "/bin"))
356 (executable "toutenclic"))
357 ;; Install icon.
358 (install-file "toutenclic.png" pixmaps)
359 ;; Move files into "share/" directory.
360 (for-each (lambda (f) (install-file f share))
361 (find-files "." "\\.py$"))
362 ;; Install documentation.
363 (install-file "ToutEnClic.pdf" doc)
364 ;; Create executable in "bin/".
365 (mkdir-p bin)
366 (with-directory-excursion bin
367 (symlink (string-append share "/" executable ".py")
368 executable)))
369 #t))
370 (add-after 'install 'create-desktop-file
371 (lambda* (#:key outputs #:allow-other-keys)
372 (let* ((out (assoc-ref outputs "out"))
373 (applications (string-append out "/share/applications")))
374 (mkdir-p applications)
375 (call-with-output-file
376 (string-append applications "/toutenclic.desktop")
377 (lambda (file)
378 (format file
379 "[Desktop Entry]~@
380 Name=ToutEnClic~@
381 Comment=For schooling without difference~@
382 Exec=~a/bin/toutenclic~@
383 TryExec=~@*~a/bin/toutenclic~@
384 Terminal=false~@
385 Icon=toutenclic~@
386 Type=Application~%"
387 out)))
388 #t))))))
389 (native-inputs
390 `(("unzip" ,unzip)))
391 (inputs
392 `(("python-pyqt" ,python-pyqt)))
393 (synopsis "School tools for physically disabled children")
394 (description "ToutEnClic is intended to facilitate the schooling
395 of physically disabled children in ordinary schools. It is both
396 a multi-page virtual exercise book and a kit including pencil,
397 scissors, glue, ruler, compass, protractor and square. A virtual
398 keyboard is also available if the child does not have any other
399 specialized device.")
400 (home-page "https://bipede.fr/contrib/")
401 (license license:gpl3)))
402
403 (define-public childsplay
404 (package
405 (name "childsplay")
406 (version "3.4")
407 (source (origin
408 (method url-fetch)
409 (uri (string-append
410 "mirror://sourceforge/schoolsplay/"
411 "childsplay-" version ".tgz"))
412 (sha256
413 (base32
414 "0z7yp2swjnbz51vn2zyfnjn40jq38l5mbh15yafmx1z3vn2z1m77"))))
415 (build-system python-build-system)
416 (arguments
417 `(#:python ,python-2
418 #:tests? #f
419 #:phases
420 (modify-phases %standard-phases
421 (add-after 'unpack 'unbundle-dejavu-font
422 (lambda* (#:key inputs #:allow-other-keys)
423 (let* ((dejavu-dir
424 (string-append (assoc-ref inputs "font-dejavu")
425 "/share/fonts/truetype"))
426 (dejavu-font
427 (string-append dejavu-dir
428 "/DejaVuSansCondensed-Bold.ttf")))
429 (substitute* "SPConstants.py"
430 (("^(TTF(BOLD)? = ).*" _ prefix)
431 (string-append prefix "'" dejavu-font "'\n")))
432 (for-each (lambda (f) (delete-file f))
433 (find-files "lib/SPData" "DejaVu"))
434 #t)))
435 (delete 'build)
436 (replace 'install
437 (lambda* (#:key outputs #:allow-other-keys)
438 (let* ((out (assoc-ref outputs "out"))
439 (pixmaps (string-append out "/share/pixmaps"))
440 (share (string-append out "/share/childsplay"))
441 (doc (string-append out "/share/doc/" ,name "-",version)))
442 ;; Install icon.
443 (install-file "lib/SPData/themes/childsplay/logo_cp.svg" pixmaps)
444 ;; Install data.
445 (mkdir-p share)
446 (for-each (lambda (f)
447 (copy-recursively f (string-append share "/" f)))
448 '("alphabet-sounds" "lib" "locale" "SPWidgets"))
449 (for-each (lambda (f) (install-file f share))
450 (find-files "." "\\.(py|dev|db)$"))
451 ;; Install documentation.
452 (mkdir-p doc)
453 (copy-recursively "docs" doc)
454 #t)))
455 (add-after 'install 'create-executable
456 (lambda* (#:key outputs inputs #:allow-other-keys)
457 (let* ((python (string-append (assoc-ref inputs "python")
458 "/bin/python"))
459 (out (assoc-ref outputs "out"))
460 (bin (string-append out "/bin"))
461 (executable (string-append bin "/childsplay")))
462 (mkdir-p bin)
463 (call-with-output-file executable
464 (lambda (file)
465 (format file
466 "~a ~a"
467 python
468 (string-append out "/share/childsplay/childsplay.py"))))
469 (chmod executable #o555)
470 #t)))
471 (add-after 'install 'create-desktop-file
472 (lambda* (#:key outputs #:allow-other-keys)
473 (let* ((out (assoc-ref outputs "out"))
474 (applications (string-append out "/share/applications")))
475 (mkdir-p applications)
476 (call-with-output-file
477 (string-append applications "/childsplay.desktop")
478 (lambda (file)
479 (format file
480 "[Desktop Entry]~@
481 Name=Childsplay~@
482 Comment=Suite of educational games for young children~@
483 Comment[ca]=Conjunt de jocs educatius per a xiquets~@
484 Comment[es]=Conjunto de juegos educativos para niños~@
485 Comment[de]=Sammlung mit lehrreichen Spielen für kleine Kinder~@
486 Exec=~a/bin/childsplay.py~@
487 Terminal=false~@
488 Icon=logo_cp.svg~@
489 Type=Application~@
490 Categories=Application;Game;Education;KidsGame;~@
491 Keywords=suite;children;games;young;educational;~%"
492 out)))
493 #t))))))
494 (inputs
495 `(("font-dejavu" ,font-dejavu)
496 ("pygame" ,python2-pygame)
497 ("sqlalchemy" ,python2-sqlalchemy)))
498 (synopsis "Suite of educational games for young children")
499 (description "Childsplay is a collection of educational activities
500 for young children. Childsplay can be used at home, kindergartens and
501 pre-schools. Childsplay is a fun and safe way to let young children
502 use the computer and at the same time teach them a little math,
503 letters of the alphabet, spelling, eye-hand coordination, etc.")
504 (home-page "http://www.schoolsplay.org")
505 (license license:gpl3+)))
506
507 (define-public omnitux
508 (package
509 (name "omnitux")
510 (version "1.2.1")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (string-append "mirror://sourceforge/omnitux/omnitux/"
515 "v" version "/omnitux-" version ".tar.bz2"))
516 (sha256
517 (base32 "1wmmmbzmxd0blhn00d4g91xwavnab143a31ca3i8hrqgzh6qz9w6"))
518 (modules '((guix build utils)))
519 (snippet
520 '(begin
521 ;; Remove pre-compiled .pyc files from source.
522 (for-each delete-file (find-files "bin" "\\.pyc$"))
523 #t))))
524 (build-system python-build-system)
525 (inputs
526 `(("python2-pygame" ,python2-pygame)
527 ("python2-pygtk" ,python2-pygtk)))
528 (arguments
529 `(#:tests? #f ;no test
530 #:python ,python-2
531 #:phases
532 (modify-phases %standard-phases
533 (delete 'build) ;no setup.py
534 (replace 'install
535 (lambda* (#:key outputs #:allow-other-keys)
536 (let* ((out (assoc-ref outputs "out"))
537 (share (string-append out "/share"))
538 (data (string-append share "/omnitux")))
539 ;; Install documentation.
540 (let ((doc (string-append share "/doc/" ,name "-" ,version)))
541 (for-each (lambda (f) (install-file f doc))
542 '("LICENSE.txt" "README.txt")))
543 ;; Install data.
544 (install-file "omnitux.sh" data)
545 (for-each (lambda (d)
546 (copy-recursively d (string-append data "/" d)))
547 '("bin" "data"))
548 ;; Install the launcher.
549 (let* ((bin (string-append out "/bin"))
550 (script (string-append bin "/omnitux"))
551 (bash (string-append (assoc-ref %build-inputs "bash")
552 "/bin/bash"))
553 (python (string-append (assoc-ref %build-inputs "python")
554 "/bin/python2")))
555 (mkdir-p bin)
556 (with-output-to-file script
557 (lambda ()
558 (format #t "#!~a~%" bash)
559 (format #t
560 "cd ~a; ~a menu.py~%"
561 (string-append data "/bin")
562 python)))
563 (chmod script #o755))
564 ;; Install icon and desktop file.
565 (let ((pixmaps (string-append share "/pixmaps")))
566 (install-file "data/default/icons/Omnitux_logo.svg" pixmaps))
567 (let ((apps (string-append out "/share/applications")))
568 (mkdir-p apps)
569 (with-output-to-file (string-append apps "/omnitux.desktop")
570 (lambda _
571 (format #t
572 "[Desktop Entry]~@
573 Name=Omnitux~@
574 GenericName=Omnitux
575 Comment=An educational game based on multimedia elements.~@
576 Comment[fr]=Un jeu ludo-éducatif basé sur des éléments multimédias.~@
577 Exec=~a/bin/omnitux~@
578 Type=Application~@
579 Categories=Game;Education;~@
580 Terminal=false~@
581 Icon=Omnitux_logo.svg~@"
582 out))))
583 #t))))))
584 (home-page "http://omnitux.sourceforge.net/")
585 (synopsis "Educational activities based on multimedia elements")
586 (description "The project aims to provide various educational
587 activities around multimedia elements (images, sounds, texts). Types
588 of activities include:
589 @itemize
590 @item associations,
591 @item items to place on a map or a schema,
592 @item counting activities,
593 @item puzzles,
594 @item card faces to remember,
595 @item find differences between two pictures,
596 @item ...
597 @end itemize
598
599 Activities are available in English, French, German, Polish,
600 Portuguese, Spanish and Italian.")
601 ;; Project's license is GPL3+, but multimedia elements are
602 ;; released under various licenses.
603 (license (list license:gpl3+
604 license:gpl2+
605 license:cc-by-sa2.0
606 license:cc-by-sa3.0
607 license:public-domain))))
608
609 (define-public fet
610 (package
611 (name "fet")
612 (version "5.45.0")
613 (source
614 (origin
615 (method url-fetch)
616 (uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
617 "fet-" version ".tar.bz2"))
618 (sha256
619 (base32 "04jns6wc20rz6cp410znsllknhp4zlf4rn8wgv712855nffs42c6"))))
620 (build-system gnu-build-system)
621 (arguments
622 `(#:phases
623 (modify-phases %standard-phases
624 (add-after 'unpack 'fix-hardcoded-directories
625 (lambda* (#:key outputs #:allow-other-keys)
626 (substitute* (list "fet.pro"
627 "src/src.pro"
628 "src/src-cl.pro"
629 "src/interface/fet.cpp")
630 (("/usr") (assoc-ref outputs "out")))
631 #t))
632 (replace 'configure
633 (lambda _ (invoke "qmake" "fet.pro"))))))
634 (inputs
635 `(("qtbase" ,qtbase)))
636 (home-page "https://www.lalescu.ro/liviu/fet/")
637 (synopsis "Timetabling software")
638 (description
639 "FET is a program for automatically scheduling the timetable of a school,
640 high-school or university. It uses a fast and efficient timetabling
641 algorithm.
642
643 Usually, FET is able to solve a complicated timetable in maximum 5-20 minutes.
644 For extremely difficult timetables, it may take a longer time, a matter of
645 hours.")
646 (license license:agpl3+)))
647
648 (define-public klavaro
649 (package
650 (name "klavaro")
651 (version "3.10")
652 (source
653 (origin
654 (method url-fetch)
655 (uri (string-append "mirror://sourceforge/klavaro/klavaro-"
656 version ".tar.bz2"))
657 (sha256
658 (base32 "0jnzdrndiq6m0bwgid977z5ghp4q61clwdlzfpx4fd2ml5x3iq95"))))
659 (build-system gnu-build-system)
660 (native-inputs
661 `(("intltool" ,intltool)
662 ("pkg-config" ,pkg-config)))
663 (inputs
664 `(("cairo" ,cairo)
665 ("curl" ,curl)
666 ("gtk+" ,gtk+)
667 ("pango" ,pango)))
668 (home-page "https://klavaro.sourceforge.io/en/index.html")
669 (synopsis "Touch typing tutor")
670 (description
671 "Klavaro is a simple tutor to teach correct typing, almost independently of
672 language and very flexible regarding to new or unknown keyboard layouts.")
673 (license license:gpl3+)))
674
675 (define-public ktouch
676 (package
677 (name "ktouch")
678 (version "19.08.3")
679 (source
680 (origin
681 (method url-fetch)
682 (uri (string-append "mirror://kde/stable/applications/"
683 version "/src/ktouch-" version ".tar.xz"))
684 (sha256
685 (base32
686 "0dqxb3xsjc2rwc9779l5fnr4crhq51bc8ln4azbgnnkzldvq6a4a"))))
687 (build-system qt-build-system)
688 (arguments
689 `(#:phases
690 (modify-phases %standard-phases
691 (add-after 'configure 'patch-makefiles
692 (lambda* (#:key inputs #:allow-other-keys)
693 (let ((qtdec (assoc-ref inputs "qtdeclarative")))
694 (substitute* '("src/CMakeFiles/ktouch_autogen.dir/build.make"
695 "src/CMakeFiles/ktouch.dir/build.make")
696 (("/gnu/store/.*qmlcachegen")
697 (string-append qtdec "/bin/qmlcachegen"))))
698 #t)))))
699 (native-inputs
700 `(("extra-cmake-modules" ,extra-cmake-modules)
701 ("kdoctools" ,kdoctools)
702 ("pkg-config" ,pkg-config)))
703 (inputs
704 `(("kcmutils" ,kcmutils)
705 ("kcompletion" ,kcompletion)
706 ("kconfig" ,kconfig)
707 ("kconfigwidgets" ,kconfigwidgets)
708 ("kcoreaddons" ,kcoreaddons)
709 ("kdeclarative" ,kdeclarative)
710 ("ki18n" ,ki18n)
711 ("kiconthemes" ,kiconthemes)
712 ("kitemviews" ,kitemviews)
713 ("kqtquickcharts" ,kqtquickcharts)
714 ("ktextwidgets" ,ktextwidgets)
715 ("kwidgetsaddons" ,kwidgetsaddons)
716 ("kwindowsystem" ,kwindowsystem)
717 ("kxmlgui" ,kxmlgui)
718 ("libxcb" ,libxcb)
719 ("libxkbfile" ,libxkbfile)
720 ("qtbase" ,qtbase)
721 ("qtdeclarative" ,qtdeclarative)
722 ("qtgraphicaleffects" ,qtgraphicaleffects)
723 ("qtquickcontrols2" ,qtquickcontrols2)
724 ("qtx11extras" ,qtx11extras)
725 ("qtxmlpatterns" ,qtxmlpatterns)))
726 (home-page "https://edu.kde.org/ktouch/")
727 (synopsis "Touch typing tutor")
728 (description
729 "KTouch is an aid for learning how to type with speed and accuracy. It
730 provides a sample text to type and indicates which fingers should be used for
731 each key. A collection of lessons are included for a wide range of different
732 languages and keyboard layouts, and typing statistics are used to dynamically
733 adjust the level of difficulty.")
734 (license license:gpl2)))
735
736 (define-public anki
737 (package
738 (name "anki")
739 ;; Later versions have dependencies on npm packages not yet in Guix.
740 (version "2.1.16")
741 (source
742 (origin
743 (method url-fetch)
744 (uri (string-append "https://apps.ankiweb.net/downloads/archive/anki-"
745 version "-source.tgz"))
746 (sha256
747 (base32 "1gfr51rnllkyzli73p4r51h5ypzfa3m7lic3m3rzpywmqwrxs07k"))
748 (patches (search-patches "anki-mpv-args.patch"))))
749 (build-system gnu-build-system)
750 (arguments
751 `(#:make-flags (list (string-append "PREFIX=" %output))
752 #:tests? #f ;no check target
753 #:modules ((guix build gnu-build-system)
754 (guix build utils)
755 (ice-9 match))
756 #:phases
757 (modify-phases %standard-phases
758 (delete 'configure) ;no configure script
759 (add-after 'install 'wrap
760 (lambda* (#:key inputs outputs #:allow-other-keys)
761 (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
762 ;; List of paths to the site-packages directories of Python
763 ;; library inputs.
764 (site-packages
765 (map (lambda (pyinput)
766 (string-append
767 (cdr pyinput)
768 "/lib/python"
769 ;; Calculate the python version to avoid breaking
770 ;; with future 3.X releases.
771 ,(version-major+minor
772 (package-version python-wrapper))
773 "/site-packages"))
774 (filter (match-lambda
775 ((label . _)
776 (string-prefix? "python-" label)))
777 inputs)))
778 (qtwebengineprocess
779 (string-append (assoc-ref inputs "qtwebengine")
780 "/lib/qt5/libexec/QtWebEngineProcess")))
781 ;; The program fails to find the QtWebEngineProcess program, so
782 ;; we set QTWEBENGINEPROCESS_PATH to help it. PYTHONPATH is
783 ;; wrapped to avoid declaring Python libraries as propagated
784 ;; inputs.
785 (for-each (lambda (program)
786 (wrap-program program
787 `("QTWEBENGINEPROCESS_PATH" =
788 (,qtwebengineprocess))
789 `("PATH" prefix (,(string-append
790 (assoc-ref inputs "mpv")
791 "/bin")))
792 `("PYTHONPATH" = ,site-packages)))
793 (find-files bin ".")))
794 #t)))))
795 (native-inputs
796 `(("xdg-utils" ,xdg-utils)))
797 (inputs
798 `(("lame" ,lame)
799 ("mpv" ,mpv)
800 ("python" ,python-wrapper)
801 ("python-beautifulsoup4" ,python-beautifulsoup4)
802 ("python-decorator" ,python-decorator)
803 ("python-distro" ,python-distro)
804 ("python-jsonschema" ,python-jsonschema)
805 ("python-markdown" ,python-markdown)
806 ("python-pyaudio" ,python-pyaudio)
807 ;; `python-pyqtwebengine' must precede `python-pyqt' in PYTHONPATH.
808 ("python-pyqtwebengine" ,python-pyqtwebengine)
809 ("python-pyqt" ,python-pyqt)
810 ("python-requests" ,python-requests)
811 ("python-send2trash" ,python-send2trash)
812 ("python-sip" ,python-sip)
813 ;; `qtwebengine' is included in `pyqtwebengine', included here for easy
814 ;; wrapping.
815 ("qtwebengine" ,qtwebengine)))
816 (home-page "https://apps.ankiweb.net/")
817 (synopsis "Powerful, intelligent flash cards")
818 (description "Anki is a program which makes remembering things
819 easy. Because it's a lot more efficient than traditional study
820 methods, you can either greatly decrease your time spent studying, or
821 greatly increase the amount you learn.
822
823 Anyone who needs to remember things in their daily life can benefit
824 from Anki. Since it is content-agnostic and supports images, audio,
825 videos and scientific markup (via LaTeX), the possibilities are
826 endless. For example:
827 @itemize
828 @item Learning a language
829 @item Studying for medical and law exams
830 @item Memorizing people's names and faces
831 @item Brushing up on geography
832 @item Mastering long poems
833 @item Even practicing guitar chords!
834 @end itemize")
835 (license license:agpl3+)))
836
837 (define-public t4k-common
838 (package
839 (name "t4k-common")
840 (version "0.1.1")
841 (source
842 (origin
843 (method git-fetch)
844 (uri (git-reference
845 (url "https://github.com/tux4kids/t4kcommon")
846 (commit (string-append "upstream/" version))))
847 (file-name (git-file-name name version))
848 (sha256
849 (base32 "13q02xpmps9qg8zrzzy2gzv4a6afgi28lxk4z242j780v0gphchp"))
850 (patches
851 (search-patches "t4k-common-libpng16.patch"))))
852 (build-system cmake-build-system)
853 (arguments
854 `(#:tests? #f ;FIXME: cannot find how to run tests
855 #:phases
856 (modify-phases %standard-phases
857 (add-after 'set-paths 'set-sdl-paths
858 (lambda* (#:key inputs #:allow-other-keys)
859 (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
860 "/include/SDL:"
861 (or (getenv "CPATH") "")))))
862 (add-after 'unpack 'fix-andika-font-path
863 (lambda* (#:key inputs #:allow-other-keys)
864 (substitute* "src/t4k_sdl.c"
865 (("(/usr/share/.*?)/AndikaDesRevG\\.ttf")
866 (string-append (assoc-ref inputs "font-andika")
867 "/share/fonts/truetype")))
868 #t)))))
869 (native-inputs
870 `(("pkg-config" ,pkg-config)))
871 (inputs
872 `(("font-andika" ,font-sil-andika)
873 ("libpng" ,libpng)
874 ("librsvg" ,librsvg)
875 ("libxml2" ,libxml2)
876 ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))))
877 (home-page "https://github.com/tux4kids/t4kcommon")
878 (synopsis "Library of code shared between TuxMath and TuxType")
879 (description "Tux4Kids-Common is a library of code shared between
880 TuxMath and TuxType.")
881 (license license:gpl3+)))
882
883 (define-public tuxmath
884 (package
885 (name "tuxmath")
886 (version "2.0.3")
887 (source
888 (origin
889 (method git-fetch)
890 (uri (git-reference
891 (url "https://github.com/tux4kids/tuxmath")
892 (commit (string-append "upstream/" version))))
893 (file-name (git-file-name name version))
894 (sha256
895 (base32 "1f1pz83w6d3mbik2h6xavfxmk5apxlngxbkh80x0m55lhniwkdxv"))
896 (modules '((guix build utils)))
897 ;; Unbundle fonts.
898 (snippet
899 `(begin
900 (for-each delete-file (find-files "data/fonts" "\\.ttf$"))
901 #t))))
902 (build-system gnu-build-system)
903 (arguments
904 `(#:tests? #f ;no test
905 #:phases
906 (modify-phases %standard-phases
907 (add-after 'set-paths 'set-sdl-paths
908 (lambda* (#:key inputs #:allow-other-keys)
909 (setenv "CPATH"
910 (string-append (assoc-ref inputs "sdl")
911 "/include/SDL:"
912 (or (getenv "CPATH") "")))
913 #t))
914 (add-after 'install 'install-desktop-file
915 (lambda* (#:key outputs #:allow-other-keys)
916 (let* ((out (assoc-ref outputs "out"))
917 (apps (string-append out "/share/applications"))
918 (pixmaps (string-append out "/share/pixmaps")))
919 (install-file "tuxmath.desktop" apps)
920 (for-each (lambda (f) (install-file f pixmaps))
921 (find-files "data/images/icons/"
922 "tuxmath\\.(png|ico|svg)$"))
923 #t))))))
924 (native-inputs
925 `(("pkg-config" ,pkg-config)))
926 (inputs
927 `(("librsvg" ,librsvg)
928 ("libxml2" ,libxml2)
929 ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))
930 ("t4k-common" ,t4k-common)))
931 (home-page "https://github.com/tux4kids/tuxmath")
932 (synopsis "Educational math tutorial game")
933 (description "@emph{Tux, of Math Command} is an educational math
934 tutorial game starring Tux, the Linux penguin, in which you play the
935 part of Commander Tux, as he defends his friends from an attack of
936 math equations. Comets are crashing towards the friendly penguins in
937 their igloos, and you must destroy the comets by solving their
938 equations.
939
940 TuxMath also includes Factoroids, a game that gives practice in
941 factoring numbers and simplifying fractions, as well as zapping rocks
942 floating through space.")
943 (license license:gpl3+)))
944
945 (define-public mdk
946 (package
947 (name "mdk")
948 (version "1.2.10")
949 (source
950 (origin
951 (method url-fetch)
952 (uri (string-append "mirror://gnu/mdk/v1.2.10/mdk-"
953 version ".tar.gz"))
954 (sha256
955 (base32
956 "1rwcq2b5vvv7318j92nxc5dayj27dpfhzc4rjiv4ccvsc0x35x5h"))))
957 (build-system gnu-build-system)
958 (arguments
959 `(#:configure-flags (list "--enable-gui=yes" "-with-readline=yes")))
960 (native-inputs
961 `(("flex" ,flex)
962 ("pkg-config" ,pkg-config)
963 ("intltool" ,intltool)
964 ("ncurses" ,ncurses)))
965 (inputs
966 `(("readline" ,readline)
967 ("glib" ,glib)
968 ("gtk+" ,gtk+)
969 ("pango" ,pango)
970 ("libglade" ,libglade)))
971 (home-page "https://www.gnu.org/software/mdk/")
972 (synopsis "Virtual development environment for Knuth's MIX")
973 (description
974 "GNU MDK is the Mix Development Kit, an emulation of the pedagogical
975 computer MIX and its assembly language MIXAL. MIX has a virtual CPU with
976 standard features such as registers, memory cells, an overflow toggle,
977 comparison flags, input-output devices, and a set of binary instructions.
978 The package includes a compiler, a virtual machine, a GUI for the virtual
979 machine, and more.")
980 (license license:gpl3+)))