gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / xlockmore.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages xlockmore)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages linux))
26
27 (define-public xlockmore
28 (package
29 (name "xlockmore")
30 (version "5.42")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "http://www.tux.org/~bagleyd/xlock/xlockmore-"
34 version "/xlockmore-" version ".tar.bz2"))
35 (sha256
36 (base32
37 "17xicps92ah9377zk65k9l1bmvzzj3bpxzzwxx21g9696l71gr0z"))))
38 (build-system gnu-build-system)
39 (arguments '(#:tests? #f)) ; no such thing as a test suite
40 (inputs
41 `(("libX11" ,libx11)
42 ("libXext" ,libxext)
43 ("libXt" ,libxt)
44 ("linux-pam" ,linux-pam)))
45 (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
46 (synopsis "Screen locker for the X Window System")
47 (description
48 "XLockMore is a classic screen locker and screen saver for the
49 X Window System.")
50 (license (bsd-style #f "See xlock.c.")
51 ;; + GPLv2 in modes/glx/biof.c.
52 )))