gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages vpn)
22 #:use-module ((guix licenses)
23 #:renamer (symbol-prefix-proc 'license:))
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages gettext)
30 #:use-module (gnu packages gnupg)
31 #:use-module (gnu packages openssl)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages xml))
35
36 (define-public gvpe
37 (package
38 (name "gvpe")
39 (version "2.25")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "mirror://gnu/gvpe/gvpe-"
43 version ".tar.gz"))
44 (sha256
45 (base32
46 "1gsipcysvsk80gvyn9jnk9g0xg4ng9yd5zp066jnmpgs52d2vhvk"))))
47 (build-system gnu-build-system)
48 (home-page "http://software.schmorp.de/pkg/gvpe.html")
49 (inputs `(("openssl" ,openssl)
50 ("zlib" ,zlib)))
51 (synopsis "Secure VPN among multiple nodes over an untrusted network")
52 (description
53 "The GNU Virtual Private Ethernet creates a virtual network
54 with multiple nodes using a variety of transport protocols. It works
55 by creating encrypted host-to-host tunnels between multiple
56 endpoints.")
57 (license license:gpl3+)))
58
59 (define-public vpnc
60 (package
61 (name "vpnc")
62 (version "0.5.3")
63 (source (origin
64 (method url-fetch)
65 (uri (string-append "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
66 version ".tar.gz"))
67 (sha256 (base32
68 "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))
69 (patches (list (search-patch "vpnc-script.patch")))))
70 (build-system gnu-build-system)
71 (inputs `(("libgcrypt" ,libgcrypt)
72 ("perl" ,perl)))
73 (arguments
74 `(#:tests? #f ; there is no check target
75 #:phases
76 (alist-replace
77 'configure
78 (lambda* (#:key outputs #:allow-other-keys)
79 (let ((out (assoc-ref outputs "out")))
80 (substitute* "Makefile"
81 (("PREFIX=/usr/local") (string-append "PREFIX=" out)))
82 (substitute* "Makefile"
83 (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out "/etc/vpnc")))))
84 %standard-phases)))
85 (synopsis "Client for Cisco VPN concentrators")
86 (description
87 "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
88 It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
89 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
90 1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
91 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
92 (license license:gpl2+) ; some file are bsd-2, see COPYING
93 (home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
94
95
96 (define-public openconnect
97 (package
98 (name "openconnect")
99 (version "4.99")
100 (source (origin
101 (method url-fetch)
102 (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
103 "openconnect-" version ".tar.gz"))
104 (sha256 (base32
105 "1rd8pap455wzkx19i0sy3cqap524b6fwcjvqynxp6lhm01di4bd6"))))
106 (build-system gnu-build-system)
107 (inputs
108 `(("libxml2" ,libxml2)
109 ("openssl" ,openssl)
110 ("vpnc" ,vpnc)
111 ("zlib" ,zlib)))
112 (native-inputs
113 `(("gettext" ,gnu-gettext)
114 ("pkg-config" ,pkg-config)))
115 (arguments
116 `(#:configure-flags
117 `(,(string-append "--with-vpnc-script="
118 (assoc-ref %build-inputs "vpnc")
119 "/etc/vpnc/vpnc-script"))))
120 (synopsis "Client for Cisco VPN")
121 (description
122 "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
123 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
124 870, 880, 1800, 2800, 3800, 7200 Series and Cisco 7301 Routers,
125 and probably others.")
126 (license license:lgpl2.1)
127 (home-page "http://www.infradead.org/openconnect/")))