gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / swig.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages swig)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pcre)
25 #:use-module (gnu packages guile)
26 #:use-module (gnu packages python)
27 #:use-module (gnu packages perl)
28 #:export (swig))
29
30 (define swig
31 (package
32 (name "swig")
33 (version "2.0.11")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://sourceforge/swig/swig-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0kj21b6syp62vx68r1j6azv9033kng68pxm1k79pm4skkzr0ny33"))))
41 (build-system gnu-build-system)
42 (arguments '(#:configure-flags '("--without-boost")
43
44 ;; FIXME: Some tests require Boost anyway. Turn them on when
45 ;; we have Boost.
46 #:tests? #f))
47 (inputs `(("pcre" ,pcre)
48
49 ;; Provide these to run the corresponding tests.
50 ("guile" ,guile-2.0)
51 ("perl" ,perl)
52 ("python" ,python-wrapper)))
53 (home-page "http://swig.org/")
54 (synopsis
55 "Interface compiler that connects C/C++ code to higher-level languages")
56 (description
57 "SWIG is an interface compiler that connects programs written in C and
58 C++ with languages such as Perl, Python, Ruby, Scheme, and Tcl. It works by
59 taking the declarations found in C/C++ header files and using them to generate
60 the wrapper code that scripting languages need to access the underlying C/C++
61 code. In addition, SWIG provides a variety of customization features that let
62 you tailor the wrapping process to suit your application.")
63
64 ;; See http://www.swig.org/Release/LICENSE for details.
65 (license gpl3+)))