gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / slim.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Guy Grant <gzg@riseup.net>
3 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages slim)
22 #:use-module ((guix licenses)
23 #:renamer (symbol-prefix-proc 'l:))
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix packages)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages gl)
30 #:use-module (gnu packages xorg)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages fontutils)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages linux))
35
36 (define-public slim
37 (package
38 (name "slim")
39 (version "1.3.6")
40 (source (origin
41 (method url-fetch)
42 ;; Used to be available from
43 ;; mirror://sourceforge/project/slim.berlios/.
44 (uri (string-append "http://download.berlios.de/slim/slim-"
45 version ".tar.gz"))
46 (sha256
47 (base32 "1pqhk22jb4aja4hkrm7rjgbgzjyh7i4zswdgf5nw862l2znzxpi1"))
48 (patches (map search-patch
49 (list "slim-config.patch" "slim-session.patch"
50 "slim-sigusr1.patch")))))
51 (build-system cmake-build-system)
52 (inputs `(("linux-pam" ,linux-pam)
53 ("libpng" ,libpng)
54 ("libjpeg" ,libjpeg)
55 ("freeglut" ,freeglut)
56 ("libxrandr" ,libxrandr)
57 ("libxrender" ,libxrender)
58 ("freetype" ,freetype)
59 ("fontconfig" ,fontconfig)
60 ("libx11" ,libx11)
61 ("libxft" ,libxft)
62 ("libxmu" ,libxmu)
63 ("xauth" ,xauth)))
64 (native-inputs
65 `(("pkg-config" ,pkg-config)))
66 (arguments
67 '(#:phases (alist-cons-before
68 'configure 'set-new-etc-location
69 (lambda _
70 (substitute* "CMakeLists.txt"
71 (("/etc")
72 (string-append (assoc-ref %outputs "out") "/etc"))
73 (("install.*systemd.*")
74 ;; The build system's logic here is: if "Linux", then
75 ;; "systemd". Strip that.
76 "")))
77 %standard-phases)
78 #:configure-flags '("-DUSE_PAM=yes"
79 "-DUSE_CONSOLEKIT=no")
80 #:tests? #f))
81 (home-page "http://slim.berlios.de/")
82 (synopsis "Desktop-independent graphcal login manager for X11")
83 (description
84 "SLiM is a Desktop-independent graphical login manager for X11, derived
85 from Login.app. It aims to be light and simple, although completely configurable
86 through themes and an option file; is suitable for machines on which remote login
87 functionalities are not needed.
88
89 Features included: PNG and XFT support for alpha transparency and antialiased fonts,
90 External themes support, Configurable runtime options: X server -- login / shutdown / reboot
91 commands, Single (GDM-like) or double (XDM-like) input control, Can load predefined user at
92 startup, Configurable welcome / shutdown messages, Random theme selection")
93 (license l:gpl2)))