gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / skribilo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages skribilo)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages guile)
25 #:use-module (gnu packages lout)
26 #:use-module (gnu packages imagemagick)
27 #:use-module (gnu packages ghostscript))
28
29 (define-public skribilo
30 (package
31 (name "skribilo")
32 (version "0.9.2")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://savannah/skribilo/skribilo-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "0wwi996403wzcp8s8iyc2p6w7f9v39lwmy35ysdd3wc31i5dy19q"))))
40 (build-system gnu-build-system)
41 (arguments
42 ;; Make the modules available under the usual location.
43 '(#:configure-flags (list (string-append "--with-guilemoduledir="
44 (assoc-ref %outputs "out")
45 "/share/guile/site/2.0"))
46 #:parallel-build? #f))
47 ;; TODO: Add Ploticus.
48 (inputs `(("guile" ,guile-2.0)
49 ("imagemagick" ,imagemagick)
50 ("ghostscript" ,ghostscript) ; for 'convert'
51 ("lout" ,lout)))
52
53 ;; The 'skribilo' command needs them, and for people using Skribilo as a
54 ;; library, these inputs are needed as well.
55 (propagated-inputs `(("guile-reader" ,guile-reader/guile-2.0)
56 ("guile-lib" ,guile-lib)))
57
58 (home-page "http://www.nongnu.org/skribilo/")
59 (synopsis "Document production tool written in Guile Scheme")
60 (description
61 "Skribilo is a free document production tool that takes a structured
62 document representation as its input and renders that document in a variety of
63 output formats: HTML and Info for on-line browsing, and Lout and LaTeX for
64 high-quality hard copies.
65
66 The input document can use Skribilo's markup language to provide information
67 about the document's structure, which is similar to HTML or LaTeX and does not
68 require expertise. Alternatively, it can use a simpler, “markup-less” format
69 that borrows from Emacs' outline mode and from other conventions used in
70 emails, Usenet and text.
71
72 Lastly, Skribilo provides Guile Scheme APIs.")
73 (license gpl3+)))