gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / screen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages screen)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages perl))
28
29 (define-public screen
30 (package
31 (name "screen")
32 (version "4.2.1")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/screen/screen-"
36 version ".tar.gz"))
37 (sha256
38 (base32 "105hp6qdd8rl71p81klmxiz4mlb60kh9r7czayrx40g38x858s2l"))))
39 (build-system gnu-build-system)
40 (inputs
41 `(("ncurses", ncurses)
42 ("perl" ,perl)))
43 (arguments
44 `(#:configure-flags
45 ;; By default, man and info pages are put in PREFIX/{man,info},
46 ;; but we want them in PREFIX/share/{man,info}.
47 (let ((out (assoc-ref %outputs "out")))
48 (list (string-append "--mandir=" out "/share/man")
49 (string-append "--infodir=" out "/share/info")))))
50 (home-page "http://www.gnu.org/software/screen/")
51 (synopsis "Full-screen window manager providing multiple terminals")
52 (description
53 "GNU Screen is a terminal window manager that multiplexes a single
54 terminal between several processes. The virtual terminals each provide
55 features such as a scroll-back buffer and a copy-and-paste mechanism. Screen
56 then manages the different virtual terminals, allowing you to easily switch
57 between them, to detach them from the current session, or even splitting the
58 view to show two terminals at once.")
59 (license gpl2+)))
60
61 (define-public dtach
62 (package
63 (name "dtach")
64 (version "0.8")
65 (source (origin
66 (method url-fetch)
67 (uri (string-append "mirror://sourceforge/dtach/dtach-"
68 version ".tar.gz"))
69 (sha256
70 (base32
71 "1agjp08zxxxfni62sqx9qsd9526yqwlz7ry07lfq3clavyylwq8n"))))
72 (build-system gnu-build-system)
73 (arguments
74 ;; No install target.
75 '(#:phases (alist-replace
76 'install
77 (lambda* (#:key outputs #:allow-other-keys)
78 (let ((out (assoc-ref outputs "out")))
79 (mkdir-p (string-append out "/bin"))
80 (copy-file "dtach" (string-append out "/bin/dtach"))))
81 %standard-phases)
82 ;; No check target.
83 #:tests? #f))
84 (home-page "http://dtach.sourceforge.net/")
85 (synopsis "Emulates the detach feature of screen")
86 (description
87 "dtach is a tiny program that emulates the detach feature of screen,
88 allowing you to run a program in an environment that is protected from the
89 controlling terminal and attach to it later.")
90 (license gpl2+)))