gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / recutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages recutils)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages emacs)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages algebra)
28 #:use-module (gnu packages curl)
29 #:use-module (gnu packages gnupg))
30
31 (define-public recutils
32 (package
33 (name "recutils")
34 (version "1.7")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/recutils/recutils-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "0cdwa4094x3yx7vn98xykvnlp9rngvd58d19vs3vh5hrvggccg93"))))
42 (build-system gnu-build-system)
43
44 ;; Running tests in parallel leads to test failures and crashes in
45 ;; torture/utils.
46 (arguments '(#:parallel-tests? #f))
47
48 (native-inputs `(("emacs" ,emacs)
49 ("bc" ,bc)))
50
51 ;; TODO: Add more optional inputs.
52 ;; FIXME: Our Bash doesn't have development headers (need for the 'readrec'
53 ;; built-in command), but it's not clear how to get them installed.
54 ;; See <https://lists.gnu.org/archive/html/bug-bash/2014-03/msg00125.html>.
55 (inputs `(("curl" ,curl)
56 ("libgcrypt" ,libgcrypt)
57 ("check" ,check)))
58 (synopsis "Manipulate plain text files as databases")
59 (description
60 "GNU Recutils is a set of tools and libraries for creating and
61 manipulating text-based, human-editable databases. Despite being text-based,
62 databases created with Recutils carry all of the expected features such as
63 unique fields, primary keys, time stamps and more. Many different field types
64 are supported, as is encryption.")
65 (license gpl3+)
66 (home-page "http://www.gnu.org/software/recutils/")))