gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / photo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages photo)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages libusb)
26 #:use-module (gnu packages autotools)
27 #:use-module (gnu packages readline)
28 #:use-module (gnu packages popt)
29 #:use-module ((gnu packages base) #:select (tzdata)))
30
31 (define-public libexif
32 (package
33 (name "libexif")
34 (version "0.6.21")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://sourceforge/libexif/libexif-"
38 version ".tar.bz2"))
39 (sha256
40 (base32
41 "06nlsibr3ylfwp28w8f5466l6drgrnydgxrm4jmxzrmk5svaxk8n"))))
42 (build-system gnu-build-system)
43 (home-page "http://libexif.sourceforge.net/")
44 (synopsis "Read and manipulate EXIF data in digital photographs")
45 (description
46 "The libexif C library allows applications to read, edit, and save EXIF
47 data as produced by digital cameras.")
48 (license lgpl2.1+)))
49
50 (define-public libgphoto2
51 (package
52 (name "libgphoto2")
53 (version "2.5.2")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append "mirror://sourceforge/gphoto/libgphoto2-"
57 version ".tar.bz2"))
58 (sha256
59 (base32
60 "0f1818l1vs5fbmrihzyv3qasddbqi3r01jik5crrxddwalsi2bd3"))))
61 (build-system gnu-build-system)
62 (native-inputs `(("pkg-config" ,pkg-config)))
63 (inputs
64 `(;; ("libjpeg-turbo" ,libjpeg-turbo)
65 ("libtool" ,libtool)
66 ("libusb" ,libusb)))
67 (propagated-inputs
68 `(;; The .pc refers to libexif.
69 ("libexif" ,libexif)))
70 (home-page "http://www.gphoto.org/proj/libgphoto2/")
71 (synopsis "Accessing digital cameras")
72 (description
73 "This is the library backend for gphoto2. It contains the code for PTP,
74 MTP, and other vendor specific protocols for controlling and transferring data
75 from digital cameras.")
76
77 ;; 'COPYING' says LGPLv2.1+, but in practices files are under LGPLv2+.
78 (license lgpl2.1+)))
79
80 (define-public gphoto2
81 (package
82 (name "gphoto2")
83 (version "2.5.2")
84 (source (origin
85 (method url-fetch)
86 (uri (string-append "mirror://sourceforge/gphoto/gphoto2-"
87 version ".tar.bz2"))
88 (sha256
89 (base32
90 "16c8k1cxfypg7v5h8xi87grclw7a5ayaamn548ys3zkj727r5fcf"))))
91 (build-system gnu-build-system)
92 (native-inputs
93 `(("pkg-config" ,pkg-config)))
94 (inputs
95 `(("readline" ,readline)
96 ;; ("libjpeg-turbo" ,libjpeg-turbo)
97 ("popt" ,popt)
98 ("libexif" ,libexif)
99 ("libgphoto2" ,libgphoto2)))
100 (arguments
101 '(#:phases (alist-cons-before
102 'check 'pre-check
103 (lambda* (#:key inputs #:allow-other-keys)
104 (substitute* (find-files "tests/data" "\\.param$")
105 (("/usr/bin/env")
106 (which "env"))))
107 %standard-phases)
108
109 ;; FIXME: There are 2 test failures, most likely related to the build
110 ;; environment.
111 #:tests? #f))
112
113 (home-page "http://www.gphoto.org/")
114 (synopsis "Command-line tools to access digital cameras")
115 (description
116 "Gphoto2 is a set of command line utilities for manipulating a large
117 number of different digital cameras. Through libgphoto2, it supports PTP,
118 MTP, and much more.")
119
120 ;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+.
121 (license gpl2+)))