gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / openssl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages openssl)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages perl)
23 #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public openssl
29 (package
30 (name "openssl")
31 (version "1.0.1h")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "ftp://ftp.openssl.org/source/openssl-" version
35 ".tar.gz"))
36 (sha256
37 (base32
38 "14yhsgag5as7nhxnw7f0vklwjwa3pmn1i15nmp3f4qxa6sc8l74x"))))
39 (build-system gnu-build-system)
40 (native-inputs `(("perl" ,perl)))
41 (arguments
42 '(#:parallel-build? #f
43 #:parallel-tests? #f
44 #:test-target "test"
45 #:phases
46 (alist-replace
47 'configure
48 (lambda* (#:key outputs #:allow-other-keys)
49 (let ((out (assoc-ref outputs "out")))
50 (zero?
51 (system* "./config"
52 "shared" ; build shared libraries
53 "--libdir=lib"
54 (string-append "--prefix=" out)))))
55 (alist-cons-before
56 'patch-source-shebangs 'patch-tests
57 (lambda* (#:key inputs native-inputs #:allow-other-keys)
58 (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
59 (substitute* (find-files "test" ".*")
60 (("/bin/sh")
61 (string-append bash "/bin/bash"))
62 (("/bin/rm")
63 "rm"))))
64 %standard-phases))))
65 (synopsis "OpenSSL, an SSL/TLS implementation")
66 (description
67 "OpenSSL is an implementation of SSL/TLS")
68 (license license:openssl)
69 (home-page "http://www.openssl.org/")))