gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / gnustep.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnustep)
20 #:use-module (guix download)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages fontutils)
26 #:use-module (gnu packages image)
27 #:use-module (gnu packages pkg-config))
28
29 (define-public windowmaker
30 (package
31 (name "windowmaker")
32 (version "0.95.5")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append
36 "http://windowmaker.org/pub/source/release/WindowMaker-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "1l3hmx4jzf6vp0zclqx9gsqrlwh4rvqm1g1zr5ha0cp0zmsg89ab"))))
41 (build-system gnu-build-system)
42 (arguments
43 '(#:phases (alist-cons-after
44 'install 'wrap
45 (lambda* (#:key outputs #:allow-other-keys)
46 (let* ((out (assoc-ref outputs "out"))
47 (bin (string-append out "/bin")))
48 ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
49 ;; which in turn wants to invoke 'wmmenugen' etc., so
50 ;; make sure everything is in $PATH.
51 (wrap-program (string-append bin "/wmaker")
52 `("PATH" ":" prefix (,bin)))))
53 %standard-phases)))
54 (inputs
55 `(("libxmu" ,libxmu)
56 ("libxft" ,libxft)
57 ("libx11" ,libx11)
58 ("fontconfig" ,fontconfig)
59 ("libjpeg" ,libjpeg)))
60 (native-inputs
61 `(("pkg-config" ,pkg-config)))
62 (home-page "http://windowmaker.org/")
63 (synopsis "NeXTSTEP-like window manager")
64 (description
65 "Window Maker is an X11 window manager originally designed to provide
66 integration support for the GNUstep Desktop Environment. In every way
67 possible, it reproduces the elegant look and feel of the NeXTSTEP user
68 interface. It is fast, feature rich, easy to configure, and easy to use.")
69
70 ;; Artwork is distributed under the WTFPL.
71 (license gpl2+)))