gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / gimp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gimp)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module ((guix licenses)
23 #:renamer (symbol-prefix-proc 'license:))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages gnome)
29 #:use-module (gnu packages image)
30 #:use-module ((gnu packages ghostscript)
31 #:select (lcms))
32 #:use-module (gnu packages compression)
33 #:use-module (gnu packages xml)
34 #:use-module (gnu packages photo)
35 #:use-module (gnu packages xorg)
36 #:use-module (gnu packages imagemagick))
37
38 (define-public babl
39 (package
40 (name "babl")
41 (version "0.1.10")
42 (source (origin
43 (method url-fetch)
44 (uri (list (string-append "http://ftp.gtk.org/pub/babl/0.1/babl-"
45 version ".tar.bz2")
46 (string-append "ftp://ftp.gtk.org/pub/babl/0.1/babl-"
47 version ".tar.bz2")))
48 (sha256
49 (base32
50 "1x2mb7zfbvk9d0a7h5cpdff9hhjsadxvqml2jay2bpf7x9nc6gwl"))))
51 (build-system gnu-build-system)
52 (home-page "http://gegl.org/babl/")
53 (synopsis "Image pixel format conversion library")
54 (description
55 "babl is a dynamic, any to any, pixel format translation library.
56 It allows converting between different methods of storing pixels known as
57 pixel formats that have with different bitdepths and other data
58 representations, color models and component permutations.
59
60 A vocabulary to formulate new pixel formats from existing primitives is
61 provided as well as the framework to add new color models and data types.")
62 (license license:lgpl3+)))
63
64 (define-public gegl
65 (package
66 (name "gegl")
67 (version "0.2.0")
68 (source (origin
69 (method url-fetch)
70 (uri (list (string-append "http://download.gimp.org/pub/gegl/"
71 (string-take version 3)
72 "/" name "-" version ".tar.bz2")))
73 (sha256
74 (base32
75 "09nlv06li9nrn74ifpm7223mxpg0s7cii702z72cpbwrjh6nlbnz"))))
76 (build-system gnu-build-system)
77 (arguments
78 `(#:phases
79 (alist-cons-before
80 'build 'pre-build
81 (lambda _
82 ;; This test program seems to crash on exit. Specifically, whilst
83 ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
84 ;; in the destructor. This is just a test program so will not have
85 ;; any wider effect, although might be hiding another problem.
86 ;; According to advice received on irc.gimp.org#gegl although 0.2.0
87 ;; is the latest released version, any bug reports against it will
88 ;; be ignored. So we are on our own.
89 (substitute* "tools/img_cmp.c"
90 (("g_object_unref \\(buffer.\\);") ""))
91
92 (substitute* "tests/compositions/Makefile"
93 (("/bin/sh") (which "bash"))))
94 %standard-phases)))
95 (inputs
96 `(("babl" ,babl)
97 ("glib" ,glib)
98 ("cairo" ,cairo)
99 ("pango" ,pango)
100 ("libpng" ,libpng)
101 ("libjpeg" ,libjpeg-8)))
102 (native-inputs
103 `(("pkg-config" ,pkg-config)
104 ("intltool" ,intltool)))
105 (home-page "http://gegl.org")
106 (synopsis "Graph based image processing framework")
107 (description "GEGL (Generic Graphics Library) provides infrastructure to
108 do demand based cached non destructive image editing on larger than RAM
109 buffers.")
110 ;; The library itself is licensed under LGPL while the sample commandline
111 ;; application and GUI binary gegl is licensed under GPL.
112 (license (list license:lgpl3+ license:gpl3+))))
113
114 (define-public gimp
115 (package
116 (name "gimp")
117 (version "2.8.10")
118 (source (origin
119 (method url-fetch)
120 (uri (string-append "http://download.gimp.org/pub/gimp/v2.8/gimp-"
121 version ".tar.bz2"))
122 (sha256
123 (base32
124 "1rha8yx0pplfjziqczjrxxp16vsvpmb5ziq3c218s4w9z4cqpzg7"))))
125 (build-system gnu-build-system)
126 (arguments
127 `(#:configure-flags
128 ;; We don't have pygtk which seems to be needed for this feature
129 `("--disable-python" )))
130 (inputs
131 `(("babl" ,babl)
132 ("glib" ,glib)
133 ("libtiff" ,libtiff)
134 ("libjpeg" ,libjpeg-8)
135 ("atk" ,atk)
136 ("gtk+" ,gtk+-2)
137 ("gegl" ,gegl)))
138 (native-inputs
139 `(("pkg-config" ,pkg-config)
140 ("intltool" ,intltool)))
141 (home-page "http://gimp.org")
142 (synopsis "GNU Image Manipulation Program")
143 (description
144 "GIMP is an application for image manipulation tasks such as photo
145 retouching, composition and authoring. It supports all common image formats
146 as well as specialized ones. It features a highly customizable interface
147 that is extensible via a plugin system.")
148 (license license:gpl3+))) ; some files are lgplv3