gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / giflib.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages giflib)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (srfi srfi-1)
25 #:use-module (gnu packages xorg)
26 #:use-module (gnu packages perl))
27
28 (define-public giflib
29 (package
30 (name "giflib")
31 (version "4.2.3")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://sourceforge/giflib/giflib-"
35 (first (string-split version #\.))
36 ".x/giflib-" version ".tar.bz2"))
37 (sha256
38 (base32 "0rmp7ipzk42r841bggd7bfqk4p8qsssbp4wcck4qnz7p4rkxbj0a"))))
39 (build-system gnu-build-system)
40 (outputs '("bin" ; utility programs
41 "out")) ; library
42 (inputs `(("libx11" ,libx11)
43 ("libice" ,libice)
44 ("libsm" ,libsm)
45 ("perl" ,perl)))
46 (arguments
47 `(#:phases (alist-cons-after
48 'unpack 'disable-html-doc-gen
49 (lambda _
50 (substitute* "doc/Makefile.in"
51 (("^all: allhtml manpages") "")))
52 (alist-cons-after
53 'install 'install-manpages
54 (lambda* (#:key outputs #:allow-other-keys)
55 (let* ((bin (assoc-ref outputs "bin"))
56 (man1dir (string-append bin "/share/man/man1")))
57 (mkdir-p man1dir)
58 (for-each (lambda (file)
59 (let ((base (basename file)))
60 (format #t "installing `~a' to `~a'~%"
61 base man1dir)
62 (copy-file file
63 (string-append
64 man1dir "/" base))))
65 (find-files "doc" "\\.1"))))
66 %standard-phases))))
67 (synopsis "Tools and library for working with GIF images")
68 (description
69 "giflib is a library for reading and writing GIF images. It is API and
70 ABI compatible with libungif which was in wide use while the LZW compression
71 algorithm was patented. Tools are also included to convert, manipulate,
72 compose, and analyze GIF images.")
73 (home-page "http://giflib.sourceforge.net/")
74 (license x11)))
75
76 ;;; giflib.scm ends here