gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / fltk.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages fltk)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages xorg)
22 #:use-module (gnu packages gl)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public fltk
28 (package
29 (name "fltk")
30 (version "1.3.2")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "http://fltk.org/pub/fltk/" version "/fltk-" version "-source.tar.gz"))
35 (sha256
36 (base32
37 "1974brlk723095vf8z72kazq1cbqr9a51kq6b0xda6zkjkgl8q0p"))))
38 (build-system gnu-build-system)
39 (inputs
40 `(("libx11" ,libx11)
41 ("mesa" ,mesa)))
42 (arguments
43 `(#:tests? #f ;TODO: compile programs in "test" dir
44 #:configure-flags '("--enable-shared")
45 #:phases
46 (alist-cons-before
47 'configure 'patch-makeinclude
48 (lambda _
49 (substitute* "makeinclude.in"
50 (("/bin/sh") (which "sh"))))
51 %standard-phases)))
52 (home-page "https://www.fltk.org")
53 (synopsis "3D C++ GUI library")
54 (description "FLTK is a C++ GUI toolkit providing modern GUI functionality without the
55 bloat. It supports 3D graphics via OpenGL and its built-in GLUT emulation.
56 FLTK is designed to be small and modular enough to be statically linked, but
57 works fine as a shared library. FLTK also includes an excellent UI builder
58 called FLUID that can be used to create applications in minutes.")
59 (license lgpl2.0))) ; plus certain additional permissions