gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / complexity.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages complexity)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages texinfo)
25 #:use-module (gnu packages autogen))
26
27 (define-public complexity
28 (package
29 (name "complexity")
30 (version "1.1")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/complexity/complexity-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "1aad7n35ymxbj5dlpvm64dcd71b6i7hbmps0g7nkf47vj53l6y2j"))))
38 (build-system gnu-build-system)
39 (native-inputs
40 `(("texinfo" ,texinfo)
41 ("autogen" ,autogen)))
42 (home-page "http://www.gnu.org/software/complexity/")
43 (synopsis "Analyze complexity of C functions")
44 (description
45 "GNU complexity provides tools for finding procedures that are
46 convoluted, overly long or otherwise difficult to understand. This
47 may help in learning or reviewing unfamiliar code or perhaps
48 highlighting your own code that seemed comprehensible when you wrote it.")
49 (license gpl3+)))