gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages aidc)
20 #:use-module (gnu packages)
21 #:use-module ((guix licenses)
22 #:renamer (symbol-prefix-proc 'license:))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages image)
27 #:use-module (guix build-system gnu))
28
29
30 (define-public barcode
31 (package
32 (name "barcode")
33 (version "0.99")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/barcode/barcode-"
37 version ".tar.xz"))
38 (sha256 (base32
39 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
40 (build-system gnu-build-system)
41 (synopsis "Convert text strings to printed bars in various standards")
42 (description "GNU Barcode is a flexible tool to produce printed barcodes
43 from text strings. It supports a variety of encoding standards and sizing
44 measurements. Barcodes can be output in PostScript or Encapsulated PostScript
45 formats.")
46 (license license:gpl3+)
47 (home-page "http://www.gnu.org/software/barcode/")))
48
49 (define-public qrencode
50 (package
51 (name "qrencode")
52 (version "3.4.3")
53 (source (origin
54 (method url-fetch)
55 (uri (string-append
56 "http://fukuchi.org/works/qrencode/qrencode-" version
57 ".tar.bz2"))
58 (sha256 (base32
59 "163sb580p570p27imc6jhkfdw15kzp8vy1jq92nip1rwa63i9myz"))))
60 (build-system gnu-build-system)
61 (inputs `(("libpng" ,libpng)))
62 (native-inputs `(("pkg-config" ,pkg-config)))
63 (synopsis "Encode data into a QR Code symbol")
64 (description "Libqrencode is a C library for encoding data in a QR Code
65 symbol, a kind of 2D symbology that can be scanned by handy terminals such as
66 a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
67 characters, and is highly robust.")
68 (license license:lgpl2.1+)
69 (home-page "http://fukuchi.org/works/qrencode")))