gnu: docbook-xsl update to 1.78.1
[jackhill/guix/guix.git] / gnu / packages / acl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages acl)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages attr)
22 #:use-module (gnu packages perl)
23 #:use-module (gnu packages gettext)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public acl
29 (package
30 (name "acl")
31 (version "2.2.51")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://savannah/acl/acl-"
36 version ".src.tar.gz"))
37 (sha256
38 (base32
39 "09aj30m49ivycl3irram8c3givc0crivjm3ymw0nhfaxrwhlb186"))))
40 (build-system gnu-build-system)
41 (arguments
42 `(#:phases
43 (alist-cons-after
44 'configure 'patch-makefile-SHELL
45 (lambda _
46 (patch-makefile-SHELL "include/buildmacros"))
47 ,(if (%current-target-system)
48 '%standard-phases
49 '(alist-replace 'check
50 (lambda _
51 (system* "make" "tests" "-C" "test")
52
53 ;; XXX: Ignore the test result since this is
54 ;; dependent on the underlying file system.
55 #t)
56 %standard-phases)))))
57 (inputs `(("attr" ,attr)
58
59 ;; Perl is needed to run tests; remove it from cross builds.
60 ,@(if (%current-target-system)
61 '()
62 `(("perl" ,perl)))))
63 (native-inputs
64 `(("gettext" ,gnu-gettext)))
65
66 (home-page
67 "http://savannah.nongnu.org/projects/acl")
68 (synopsis
69 "Library and tools for manipulating access control lists")
70 (description
71 "Library and tools for manipulating access control lists.")
72 (license (list gpl2+ lgpl2.1+))))