gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / sooperlooper-build-with-wx-30.patch
1 Downloaded from https://anonscm.debian.org/cgit/pkg-multimedia/sooperlooper.git/plain/debian/patches/04-build_with_wx_30.patch -O gnu/packages/patches/sooperlooper-build-with-wx-30.patch
2
3 Author: Jaromír Mikeš <mira.mikes@seznam.cz>, Olly Betts <olly@survex.com>
4 Description: build against wx 3.0.
5 Forwarded: yes
6
7 Index: sooperlooper/src/gui/main_panel.cpp
8 ===================================================================
9 --- sooperlooper.orig/src/gui/main_panel.cpp
10 +++ sooperlooper/src/gui/main_panel.cpp
11 @@ -448,7 +448,7 @@ MainPanel::init_loopers (int count)
12 while (count < (int)_looper_panels.size()) {
13 looperpan = _looper_panels.back();
14 _looper_panels.pop_back();
15 - _main_sizer->Remove(looperpan);
16 + _main_sizer->Detach(looperpan);
17 looperpan->Destroy();
18 }
19 }
20 @@ -1277,7 +1277,7 @@ void MainPanel::misc_action (bool releas
21 }
22
23
24 - wxString filename = do_file_selector (wxT("Choose file to save loop"), wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
25 + wxString filename = do_file_selector (wxT("Choose file to save loop"), wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
26
27 if ( !filename.empty() )
28 {
29 @@ -1296,7 +1296,7 @@ void MainPanel::misc_action (bool releas
30 index = 0;
31 }
32
33 - wxString filename = do_file_selector (wxT("Choose file to open"), wxT(""), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
34 + wxString filename = do_file_selector (wxT("Choose file to open"), wxT(""), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
35
36 if ( !filename.empty() )
37 {
38 @@ -1408,7 +1408,7 @@ void MainPanel::set_curr_loop (int index
39
40 void MainPanel::do_load_session ()
41 {
42 - wxString filename = do_file_selector (wxT("Choose session to load"), wxT("*.slsess"), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
43 + wxString filename = do_file_selector (wxT("Choose session to load"), wxT("*.slsess"), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
44
45 if ( !filename.empty() )
46 {
47 @@ -1419,7 +1419,7 @@ void MainPanel::do_load_session ()
48
49 void MainPanel::do_save_session (bool write_audio)
50 {
51 - wxString filename = do_file_selector (wxT("Choose file to save session"), wxT("slsess"), wxT("*.slsess"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
52 + wxString filename = do_file_selector (wxT("Choose file to save session"), wxT("slsess"), wxT("*.slsess"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
53
54 if ( !filename.empty() )
55 {
56 Index: sooperlooper/src/gui/pix_button.cpp
57 ===================================================================
58 --- sooperlooper.orig/src/gui/pix_button.cpp
59 +++ sooperlooper/src/gui/pix_button.cpp
60 @@ -250,7 +250,7 @@ PixButton::OnMouseEvents (wxMouseEvent &
61 pt.x += bounds.x;
62 pt.y += bounds.y;
63
64 - if (bounds.Inside(pt)) {
65 + if (bounds.Contains(pt)) {
66 clicked (get_mouse_button(ev)); // emit
67
68 if (ev.MiddleUp() && ev.ControlDown()) {
69 Index: sooperlooper/src/gui/looper_panel.cpp
70 ===================================================================
71 --- sooperlooper.orig/src/gui/looper_panel.cpp
72 +++ sooperlooper/src/gui/looper_panel.cpp
73 @@ -1428,7 +1428,7 @@ LooperPanel::clicked_events (int button,
74 if (cmd == wxT("save"))
75 {
76 wxString filename = _mainpanel->do_file_selector (wxT("Choose file to save loop"),
77 - wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
78 + wxT("wav"), wxT("WAVE files (*.wav)|*.wav;*.WAV;*.Wav"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
79
80 if ( !filename.empty() )
81 {
82 @@ -1442,7 +1442,7 @@ LooperPanel::clicked_events (int button,
83 }
84 else if (cmd == wxT("load"))
85 {
86 - wxString filename = _mainpanel->do_file_selector(wxT("Choose file to open"), wxT(""), wxT("Audio files (*.wav,*.aif)|*.wav;*.WAV;*.Wav;*.aif;*.aiff;*.AIF;*.AIFF|All files (*.*)|*.*"), wxOPEN|wxCHANGE_DIR);
87 + wxString filename = _mainpanel->do_file_selector(wxT("Choose file to open"), wxT(""), wxT("Audio files (*.wav,*.aif)|*.wav;*.WAV;*.Wav;*.aif;*.aiff;*.AIF;*.AIFF|All files (*.*)|*.*"), wxFD_OPEN|wxFD_CHANGE_DIR);
88
89 if ( !filename.empty() )
90 {
91 Index: sooperlooper/src/gui/keyboard_target.cpp
92 ===================================================================
93 --- sooperlooper.orig/src/gui/keyboard_target.cpp
94 +++ sooperlooper/src/gui/keyboard_target.cpp
95 @@ -553,10 +553,10 @@ KeyboardTarget::keycode_from_name (const
96 keycode = WXK_RETURN;
97 }
98 else if ( keyname == wxT("PGUP") ) {
99 - keycode = WXK_PRIOR;
100 + keycode = WXK_PAGEUP;
101 }
102 else if ( keyname == wxT("PGDN") ) {
103 - keycode = WXK_NEXT;
104 + keycode = WXK_PAGEDOWN;
105 }
106 else if ( keyname == wxT("LEFT") ) {
107 keycode = WXK_LEFT;
108 @@ -630,10 +630,10 @@ wxString KeyboardTarget::name_from_keyco
109 case WXK_RETURN:
110 text += wxT("return");
111 break;
112 - case WXK_PRIOR:
113 + case WXK_PAGEUP:
114 text += wxT("pageup");
115 break;
116 - case WXK_NEXT:
117 + case WXK_PAGEDOWN:
118 text += wxT("pagedown");
119 break;
120 case WXK_LEFT:
121 Index: sooperlooper/src/gui/check_box.cpp
122 ===================================================================
123 --- sooperlooper.orig/src/gui/check_box.cpp
124 +++ sooperlooper/src/gui/check_box.cpp
125 @@ -237,7 +237,7 @@ CheckBox::OnMouseEvents (wxMouseEvent &e
126 }
127 else if (ev.LeftUp())
128 {
129 - if (bounds.Inside(ev.GetPosition())) {
130 + if (bounds.Contains(ev.GetPosition())) {
131 // toggle value
132 _value = !_value;
133
134 Index: sooperlooper/src/gui/midi_bind_panel.cpp
135 ===================================================================
136 --- sooperlooper.orig/src/gui/midi_bind_panel.cpp
137 +++ sooperlooper/src/gui/midi_bind_panel.cpp
138 @@ -880,7 +880,7 @@ void MidiBindPanel::on_button (wxCommand
139 }
140 else if (ev.GetId() == ID_LoadButton)
141 {
142 - wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to open"), wxT(""), wxT("*.slb"), wxOPEN|wxCHANGE_DIR);
143 + wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to open"), wxT(""), wxT("*.slb"), wxFD_OPEN|wxFD_CHANGE_DIR);
144 if ( !filename.empty() )
145 {
146 _parent->get_loop_control().load_midi_bindings(filename, _append_check->GetValue());
147 @@ -888,7 +888,7 @@ void MidiBindPanel::on_button (wxCommand
148 }
149 else if (ev.GetId() == ID_SaveButton)
150 {
151 - wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to save"), wxT(""), wxT("*.slb"), wxSAVE|wxCHANGE_DIR|wxOVERWRITE_PROMPT);
152 + wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to save"), wxT(""), wxT("*.slb"), wxFD_SAVE|wxFD_CHANGE_DIR|wxFD_OVERWRITE_PROMPT);
153
154 if ( !filename.empty() )
155 {
156 Index: sooperlooper/src/gui/config_panel.cpp
157 ===================================================================
158 --- sooperlooper.orig/src/gui/config_panel.cpp
159 +++ sooperlooper/src/gui/config_panel.cpp
160 @@ -378,7 +378,7 @@ void ConfigPanel::on_button (wxCommandEv
161 else if (ev.GetId() == ID_MidiBrowseButton) {
162
163 _parent->get_keyboard().set_enabled(false);
164 - wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to use"), wxT(""), wxT("*.slb"), wxOPEN|wxCHANGE_DIR);
165 + wxString filename = _parent->do_file_selector(wxT("Choose midi binding file to use"), wxT(""), wxT("*.slb"), wxFD_OPEN|wxFD_CHANGE_DIR);
166 _parent->get_keyboard().set_enabled(true);
167
168 if ( !filename.empty() )
169 @@ -389,8 +389,8 @@ void ConfigPanel::on_button (wxCommandEv
170 else if (ev.GetId() == ID_SessionBrowseButton) {
171
172 _parent->get_keyboard().set_enabled(false);
173 - wxString filename = _parent->do_file_selector(wxT("Choose session file to use"), wxT(""), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
174 - //wxString filename = wxFileSelector(wxT("Choose session file to use"), wxT(""), wxT(""), wxT(""), wxT("*.slsess"), wxOPEN|wxCHANGE_DIR);
175 + wxString filename = _parent->do_file_selector(wxT("Choose session file to use"), wxT(""), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
176 + //wxString filename = wxFileSelector(wxT("Choose session file to use"), wxT(""), wxT(""), wxT(""), wxT("*.slsess"), wxFD_OPEN|wxFD_CHANGE_DIR);
177 _parent->get_keyboard().set_enabled(true);
178
179 if ( !filename.empty() )