gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / python2-rdflib-drop-sparqlwrapper.patch
1 Drop SPARQLWrapper from the required install inputs under Python 2, as it
2 creates a circular dependency.
3
4 diff -u rdflib-4.1.2.alt/setup.py rdflib-4.1.2/setup.py
5 --- rdflib-4.1.2.alt/setup.py 2014-03-04 12:40:26.000000000 +0100
6 +++ rdflib-4.1.2/setup.py 2015-01-23 21:52:59.000000000 +0100
7 @@ -52,7 +52,7 @@
8 kwargs['test_suite'] = "nose.collector"
9 kwargs['install_requires'] = [
10 'isodate',
11 - 'pyparsing', 'SPARQLWrapper']
12 + 'pyparsing']
13
14 if sys.version_info[1]<7: # Python 2.6
15 kwargs['install_requires'].append('ordereddict')
16