gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / python-fix-tests.patch
1 See the discussion about the issues fixed here at:
2 http://bugs.python.org/issue20868 .
3
4 --- Lib/test/test_shutil.py 2014-03-01 03:02:36.088311000 +0100
5 +++ Lib/test/test_shutil.py 2014-03-01 04:56:37.768311000 +0100
6 @@ -1127,6 +1127,7 @@
7 self.assertRaises(ValueError, make_archive, base_name, 'xxx')
8
9 @support.requires_zlib
10 + @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
11 def test_make_archive_owner_group(self):
12 # testing make_archive with owner and group, with various combinations
13 # this works even if there's not gid/uid support
14 @@ -1155,6 +1156,7 @@
15
16
17 @support.requires_zlib
18 + @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
19 @unittest.skipUnless(UID_GID_SUPPORT, "Requires grp and pwd support")
20 def test_tarfile_root_owner(self):
21 root_dir, base_dir = self._create_files()
22 --- Lib/test/test_socket.py.orig 2014-03-02 22:14:12.264311000 +0100
23 +++ Lib/test/test_socket.py 2014-03-21 03:50:45.660311000 +0100
24 @@ -819,6 +819,8 @@
25 self.assertRaises(OverflowError, socket.htonl, k)
26 self.assertRaises(OverflowError, socket.htons, k)
27
28 + @unittest.skipUnless(os.path.exists("/etc/services"),
29 + "getservbyname uses /etc/services, which is not in the chroot")
30 def testGetServBy(self):
31 eq = self.assertEqual
32 # Find one service that exists, then check all the related interfaces.
33 @@ -1104,6 +1106,8 @@
34 self.assertRaises(ValueError, s.ioctl, -1, None)
35 s.ioctl(socket.SIO_KEEPALIVE_VALS, (1, 100, 100))
36
37 + @unittest.skipUnless(os.path.exists("/etc/gai.conf"),
38 + "getaddrinfo() will fail")
39 def testGetaddrinfo(self):
40 try:
41 socket.getaddrinfo('localhost', 80)
42 @@ -1174,6 +1178,8 @@
43 # only IP addresses are allowed
44 self.assertRaises(socket.error, socket.getnameinfo, ('mail.python.org',0), 0)
45
46 + @unittest.skipUnless(os.path.exists("/etc/gai.conf"),
47 + "getaddrinfo() will fail")
48 @unittest.skipUnless(support.is_resource_enabled('network'),
49 'network is not enabled')
50 def test_idna(self):
51 --- Lib/test/_test_multiprocessing.py 2014-04-06 23:12:27.575235000 +0200
52 +++ Lib/test/_test_multiprocessing.py 2014-04-06 23:13:04.827235000 +0200
53 @@ -1016,6 +1016,7 @@
54 if pid is not None:
55 os.kill(pid, signal.SIGINT)
56
57 + @unittest.skipIf(True, "This fails for unknown reasons on Guix")
58 def test_wait_result(self):
59 if isinstance(self, ProcessesMixin) and sys.platform != 'win32':
60 pid = os.getpid()
61 --- Lib/ctypes/test/test_libc.py 2014-04-07 23:17:41.351235000 +0200
62 +++ Lib/ctypes/test/test_libc.py 2014-04-07 23:32:18.799235000 +0200
63 @@ -2,6 +2,7 @@
64
65 from ctypes import *
66 import _ctypes_test
67 +import platform
68
69 lib = CDLL(_ctypes_test.__file__)
70
71 @@ -17,6 +18,8 @@
72 import math
73 self.assertEqual(lib.my_sqrt(2.0), math.sqrt(2.0))
74
75 + @unittest.skipIf(platform.machine() in ['mips64'],
76 + "This test fails on this platform")
77 def test_qsort(self):
78 comparefunc = CFUNCTYPE(c_int, POINTER(c_char), POINTER(c_char))
79 lib.my_qsort.argtypes = c_void_p, c_size_t, c_size_t, comparefunc
80 --- Lib/ctypes/test/test_callbacks.py 2014-04-07 23:15:42.835235000 +0200
81 +++ Lib/ctypes/test/test_callbacks.py 2014-04-07 23:32:42.035235000 +0200
82 @@ -1,6 +1,7 @@
83 import unittest
84 from ctypes import *
85 import _ctypes_test
86 +import platform
87
88 class Callbacks(unittest.TestCase):
89 functype = CFUNCTYPE
90 @@ -174,6 +175,8 @@
91
92 self.assertLess(diff, 0.01, "%s not less than 0.01" % diff)
93
94 + @unittest.skipIf(platform.machine() in ['mips64'],
95 + "This test fails on this platform")
96 def test_issue_8959_a(self):
97 from ctypes.util import find_library
98 libc_path = find_library("c")
99 --- Tools/scripts/run_tests.py.orig 2015-04-06 03:52:17.484000000 +0200
100 +++ Tools/scripts/run_tests.py 2015-04-06 03:52:25.880000000 +0200
101 @@ -47,7 +47,7 @@
102 if threading and not any(is_multiprocess_flag(arg) for arg in regrtest_args):
103 args.extend(['-j', '0']) # Use all CPU cores
104 if not any(is_resource_use_flag(arg) for arg in regrtest_args):
105 - args.extend(['-u', 'all,-largefile,-audio,-gui'])
106 + args.extend(['-u', 'all,-largefile,-audio,-gui,-network'])
107 args.extend(regrtest_args)
108 print(' '.join(args))
109 os.execv(sys.executable, args)
110 --- Lib/distutils/tests/test_archive_util.py.orig 2015-04-06 04:08:49.288000000 +0200
111 +++ Lib/distutils/tests/test_archive_util.py 2015-04-06 04:09:34.396000000 +0200
112 @@ -282,6 +282,7 @@
113 finally:
114 del ARCHIVE_FORMATS['xxx']
115
116 + @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
117 def test_make_archive_owner_group(self):
118 # testing make_archive with owner and group, with various combinations
119 # this works even if there's not gid/uid support
120 @@ -310,6 +311,7 @@
121
122 @unittest.skipUnless(ZLIB_SUPPORT, "Requires zlib")
123 @unittest.skipUnless(UID_GID_SUPPORT, "Requires grp and pwd support")
124 + @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
125 def test_tarfile_root_owner(self):
126 tmpdir, tmpdir2, base_name = self._create_files()
127 old_dir = os.getcwd()
128 --- Lib/distutils/tests/test_sdist.py.orig 2015-04-06 04:10:05.264000000 +0200
129 +++ Lib/distutils/tests/test_sdist.py 2015-04-06 04:10:21.448000000 +0200
130 @@ -435,6 +435,7 @@
131 "The tar command is not found")
132 @unittest.skipIf(find_executable('gzip') is None,
133 "The gzip command is not found")
134 + @unittest.skipIf(True, "getgrgid(0)[0] raises a KeyError on Guix")
135 def test_make_distribution_owner_group(self):
136 # now building a sdist
137 dist, cmd = self.get_cmd()
138 --- Lib/test/test_resource.py.orig 2015-04-06 21:30:24.708000000 +0200
139 +++ Lib/test/test_resource.py 2015-04-06 23:07:27.220000000 +0200
140 @@ -146,6 +146,7 @@
141
142 @unittest.skipUnless(hasattr(resource, 'prlimit'), 'no prlimit')
143 @support.requires_linux_version(2, 6, 36)
144 + @unittest.skipIf(True, "Bug: the PermissionError is not raised")
145 def test_prlimit(self):
146 self.assertRaises(TypeError, resource.prlimit)
147 if os.geteuid() != 0: