gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / plotutils-libpng-jmpbuf.patch
1 Use the `png_jmpbuf' accessor, as recommended since libpng 1.4.0:
2 http://www.libpng.org/pub/png/src/libpng-1.2.x-to-1.4.x-summary.txt .
3
4 --- plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:12.000000000 +0200
5 +++ plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:07.000000000 +0200
6 @@ -164,7 +164,7 @@ _pl_z_maybe_output_image (S___(Plotter *
7 }
8
9 /* cleanup after libpng errors (error handler does a longjmp) */
10 - if (setjmp (png_ptr->jmpbuf))
11 + if (setjmp (png_jmpbuf (png_ptr)))
12 {
13 png_destroy_write_struct (&png_ptr, (png_info **)NULL);
14 return -1;
15 @@ -444,7 +444,7 @@ _our_error_fn_stdio (png_struct *png_ptr
16 #endif
17 }
18
19 - longjmp (png_ptr->jmpbuf, 1);
20 + longjmp (png_jmpbuf (png_ptr), 1);
21 }
22
23 static void