gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / libtiff-CVE-2018-10963.patch
1 Fix CVE-2018-10963:
2
3 http://bugzilla.maptools.org/show_bug.cgi?id=2795
4 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10963
5
6 Patch copied from upstream source repository:
7
8 https://gitlab.com/libtiff/libtiff/commit/de144fd228e4be8aa484c3caf3d814b6fa88c6d9
9
10 From de144fd228e4be8aa484c3caf3d814b6fa88c6d9 Mon Sep 17 00:00:00 2001
11 From: Even Rouault <even.rouault@spatialys.com>
12 Date: Sat, 12 May 2018 14:24:15 +0200
13 Subject: [PATCH] TIFFWriteDirectorySec: avoid assertion. Fixes
14 http://bugzilla.maptools.org/show_bug.cgi?id=2795. CVE-2018-10963
15
16 ---
17 libtiff/tif_dirwrite.c | 7 +++++--
18 1 file changed, 5 insertions(+), 2 deletions(-)
19
20 diff --git a/libtiff/tif_dirwrite.c b/libtiff/tif_dirwrite.c
21 index 2430de6d..c15a28db 100644
22 --- a/libtiff/tif_dirwrite.c
23 +++ b/libtiff/tif_dirwrite.c
24 @@ -695,8 +695,11 @@ TIFFWriteDirectorySec(TIFF* tif, int isimage, int imagedone, uint64* pdiroff)
25 }
26 break;
27 default:
28 - assert(0); /* we should never get here */
29 - break;
30 + TIFFErrorExt(tif->tif_clientdata,module,
31 + "Cannot write tag %d (%s)",
32 + TIFFFieldTag(o),
33 + o->field_name ? o->field_name : "unknown");
34 + goto bad;
35 }
36 }
37 }
38 --
39 2.17.0
40