gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / clementine-fix-sqlite.patch
1 Patch downloaded from https://github.com/clementine-player/Clementine/pull/5669 .
2
3 diff -ruN clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp clementine-1.3.1.565.gd20c2244a/src/core/database.cpp
4 --- clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp 2018-07-07 23:59:24.018540126 +0200
5 +++ clementine-1.3.1.565.gd20c2244a/src/core/database.cpp 2018-07-08 00:04:47.991551728 +0200
6 @@ -265,6 +265,17 @@
7 StaticInit();
8
9 {
10 +
11 +#ifdef SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER
12 + // In case sqlite>=3.12 is compiled without -DSQLITE_ENABLE_FTS3_TOKENIZER
13 + // (generally a good idea due to security reasons) the fts3 support should be enabled explicitly.
14 + QVariant v = db.driver()->handle();
15 + if (v.isValid() && qstrcmp(v.typeName(), "sqlite3*") == 0) {
16 + sqlite3 *handle = *static_cast<sqlite3**>(v.data());
17 + if (handle) sqlite3_db_config(handle, SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER, 1, NULL);
18 + }
19 +#endif
20 +
21 QSqlQuery set_fts_tokenizer(db);
22 set_fts_tokenizer.prepare("SELECT fts3_tokenizer(:name, :pointer)");
23 set_fts_tokenizer.bindValue(":name", "unicode");