gnu: gnucash: Disable the stress-options-test using a phase.
[jackhill/guix/guix.git] / gnu / packages / patches / abiword-black-drawing-with-gtk322.patch
1 commit 2ee38d1881aeea27bb49acc450631d813d1f28ba
2 Author: Hubert Figuière <hub@figuiere.net>
3 Date: Wed Dec 7 09:44:01 2016 -0500
4
5 Bug 13815 - draw event should return TRUE
6
7 This fix the black drawing regression witj Gtk3.22
8
9 diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
10 index 780000e..10f8e00 100644
11 --- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
12 +++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
13 @@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
14 }
15
16 #if GTK_CHECK_VERSION(3,0,0)
17 -gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
18 +gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
19 #else
20 -gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
21 +gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
22 #endif
23 {
24 XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
25 @@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
26 pView->draw(&rClip);
27 #endif
28 }
29 - return FALSE;
30 + return TRUE;
31 }
32
33 static bool bScrollWait = false;
34 diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
35 index 30ee5d8..a0ff57f 100644
36 --- a/src/af/xap/gtk/xap_UnixFrameImpl.h
37 +++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
38 @@ -152,9 +152,9 @@ protected:
39 static gint key_release_event(GtkWidget* w, GdkEventKey* e);
40 static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
41 #if GTK_CHECK_VERSION(3,0,0)
42 - static gint draw(GtkWidget * w, cairo_t * cr);
43 + static gboolean draw(GtkWidget * w, cairo_t * cr);
44 #else
45 - static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
46 + static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
47 #endif
48 static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
49 static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);