Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / wdiff.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages wdiff)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages texinfo)
25 #:use-module (gnu packages screen)
26 #:use-module (gnu packages which))
27
28 (define-public wdiff
29 (package
30 (name "wdiff")
31 (version "1.2.1")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/wdiff/wdiff-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "1gb5hpiyikada9bwz63q3g96zs383iskiir0xsqynqnvq1vd4n41"))))
40 (build-system gnu-build-system)
41 (arguments
42 `(#:phases (alist-cons-before
43 'check 'fix-sh
44 (lambda _
45 (substitute* "tests/testsuite"
46 (("#! /bin/sh")
47 (string-append "#!" (which "sh")))))
48 %standard-phases)))
49 (inputs `(("screen" ,screen)
50 ("which" ,which)
51
52 ;; For some reason wdiff.info gets rebuilt.
53 ("texinfo" ,texinfo)))
54 (home-page "https://www.gnu.org/software/wdiff/")
55 (synopsis "Word difference finder")
56 (description
57 "Wdiff is a front-end to the diff program from Diffutils that allows
58 you to compare files on a word-by-word basis, where a word is anything
59 between whitespace.")
60 (license gpl3+)))