Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / unrtf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages unrtf)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public unrtf
26 (package
27 (name "unrtf")
28 (version "0.19.7")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://gnu/unrtf/" version
32 "/unrtf-" version ".tar.gz"))
33 (sha256
34 (base32
35 "1c15miv4ni395wix6qxiqgjfspd6ssdk1ly6mm8srh0jgpidgjzf"))))
36 (build-system gnu-build-system)
37 (arguments
38 '(#:phases (alist-replace
39 'configure
40 (lambda* (#:key outputs #:allow-other-keys)
41 ;; No `configure' script; do it by hand.
42 (let ((out (assoc-ref outputs "out")))
43 (substitute* "Makefile"
44 (("/usr/local") out))))
45 %standard-phases)
46
47 ;; There are test files, but apparently no automated test suite.
48 #:tests? #f))
49 (home-page "http://www.gnu.org/software/unrtf")
50 (synopsis "Convert Rich Text Format documents to other formats")
51 (description
52 "UnRTF is a program for converting text documents from RTF to HTML,
53 LaTeX, or troff macros. It supports changes in font characteristics,
54 underlines and strikethroughs, superscripts and subscripts, and more.")
55 (license gpl2+)))