Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / shishi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages shishi)
21 #:use-module ((guix licenses) #:select (gpl3+))
22 #:use-module (gnu packages)
23 #:use-module (gnu packages gnutls)
24 #:use-module (gnu packages gnupg)
25 #:use-module (gnu packages compression)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30 (define-public shishi
31 (package
32 (name "shishi")
33 (version "1.0.2")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/shishi/shishi-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
42 (build-system gnu-build-system)
43 (inputs
44 `(("gnutls" ,gnutls)
45 ("zlib" ,zlib)
46 ("libgcrypt" ,libgcrypt)
47 ("libtasn1" ,libtasn1)))
48 (home-page "http://www.gnu.org/software/shishi/")
49 (synopsis "Implementation of the Kerberos 5 network security system")
50 (description
51 "Shishi is a free implementation of the Kerberos 5 network security
52 system. It is used to allow non-secure network nodes to communicate in a
53 secure manner through client-server mutual authentication via tickets.")
54 (license gpl3+)))