Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / screen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages screen)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages ncurses)
26 #:use-module (gnu packages perl))
27
28 (define-public screen
29 (package
30 (name "screen")
31 (version "4.0.3")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/screen/screen-"
35 version ".tar.gz"))
36 (sha256
37 (base32 "0xvckv1ia5pjxk7fs4za6gz2njwmfd54sc464n8ab13096qxbw3q"))))
38 (build-system gnu-build-system)
39 (inputs
40 `(("ncurses", ncurses)
41 ("perl" ,perl)))
42 (home-page "http://www.gnu.org/software/screen/")
43 (synopsis "Full-screen window manager providing multiple terminals")
44 (description
45 "Screen is a terminal window manager that multiplexes a single terminal
46 between several processes. The virtual terminals each provide features such
47 as a scroll-back buffer and a copy-and-paste mechanism. Screen then manages
48 the different virtual terminals, allowing you to easily switch between them,
49 to detach them from the current session, or even splitting the view to show
50 two terminals at once.")
51 (license gpl2+)))