Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / oggvorbis.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages oggvorbis)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages bison)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages curl)
25 #:use-module (gnu packages libpng)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages pulseaudio)
30 #:use-module ((guix licenses)
31 #:renamer (symbol-prefix-proc 'license:))
32 #:use-module (guix packages)
33 #:use-module (guix download)
34 #:use-module (guix build-system gnu)
35 #:export (libogg
36 libvorbis
37 speex
38 ao
39 flac
40 libkate
41 vorbis-tools))
42
43 (define libogg
44 (package
45 (name "libogg")
46 (version "1.3.0")
47 (source (origin
48 (method url-fetch)
49 (uri (string-append "http://downloads.xiph.org/releases/ogg/libogg-"
50 version ".tar.xz"))
51 (sha256
52 (base32
53 "0jy79ffkl34vycnwfsj4svqsdg1lwy2l1rr49y8r4d44kh12a5r3"))))
54 (build-system gnu-build-system)
55 (synopsis "libogg, a library for manipulating the ogg multimedia format")
56 (description
57 "The libogg library allows to manipulate the ogg multimedia container
58 format, which encapsulates raw compressed data and allows the interleaving of
59 audio and video data. In addition to encapsulation and interleaving of
60 multiple data streams, ogg provides packet framing, error detection, and
61 periodic timestamps for seeking.")
62 (license (license:bsd-style "file://COPYING"
63 "See COPYING in the distribution."))
64 (home-page "http://xiph.org/ogg/")))
65
66 (define libvorbis
67 (package
68 (name "libvorbis")
69 (version "1.3.3")
70 (source (origin
71 (method url-fetch)
72 (uri (string-append "http://downloads.xiph.org/releases/vorbis/libvorbis-"
73 version ".tar.xz"))
74 (sha256
75 (base32
76 "1gby6hapz9njx4l9g0pndyk4q83z5fgrgc30mfwfgx7bllspsk43"))))
77 (build-system gnu-build-system)
78 (propagated-inputs `(("libogg" ,libogg)))
79 (arguments `(#:configure-flags '("LDFLAGS=-lm")))
80 (synopsis "libvorbis, a library implementing the vorbis audio format")
81 (description
82 "The libvorbis library implements the ogg vorbis audio format,
83 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
84 compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit,
85 polyphonic) audio and music at fixed and variable bitrates from 16 to
86 128 kbps/channel.")
87 (license (license:bsd-style "file://COPYING"
88 "See COPYING in the distribution."))
89 (home-page "http://xiph.org/vorbis/")))
90
91 (define speex
92 (package
93 (name "speex")
94 (version "1.2rc1")
95 (source
96 (origin
97 (method url-fetch)
98 (uri (string-append "http://downloads.xiph.org/releases/speex/speex-"
99 version ".tar.gz"))
100 (sha256
101 (base32
102 "19mpkhbz3s08snvndn0h1dk2j139max6b0rr86nnsjmxazf30brl"))))
103 (build-system gnu-build-system)
104 (inputs `(("libogg" ,libogg)))
105 (home-page "https://gnu.org/software/speex")
106 (synopsis "Library for patent-free audio compression format")
107 (description
108 "Speex is a patent-free audio compression codec specially designed for
109 speech. It is well-adapted to internet applications, such as VoIP. It
110 features compression of different bands in the same bitstream, intensity
111 stereo encoding, and voice activity detection.")
112 ;; 'src/getopt.c' is under LGPLv2+
113 (license (license:bsd-style "file://COPYING"
114 "See COPYING in the distribution."))))
115
116 (define ao
117 (package
118 (name "ao")
119 (version "1.1.0")
120 (source
121 (origin
122 (method url-fetch)
123 (uri (string-append "http://downloads.xiph.org/releases/ao/libao-"
124 version ".tar.gz"))
125 (sha256
126 (base32
127 "1m0v2y6bhr4iwsgdkc7b3y0qgpvpv1ifbxsy8n8ahsvjn6wmppi9"))))
128 (build-system gnu-build-system)
129 ;; FIXME: Add further backends, see the summary printed after configure.
130 ;; XXX: Should back-ends be pushed to different outputs? For instance,
131 ;; "out" would include only the ALSA back-end, while "pulse" would
132 ;; contains 'lib/ao/plugins-4/libpulse.*'.
133 (inputs `(("pkg-config" ,pkg-config)
134 ("alsa-lib" ,alsa-lib)
135 ("pulseaudio" ,pulseaudio)))
136 (synopsis "Cross platform audio library")
137 (description
138 "Libao is a cross-platform audio library that allows programs to
139 output audio using a simple API on a wide variety of platforms.
140 It currently supports:
141 Null output (handy for testing without a sound device),
142 WAV files,
143 AU files,
144 RAW files,
145 OSS (Open Sound System, used on Linux and FreeBSD),
146 ALSA (Advanced Linux Sound Architecture),
147 aRts (Analog RealTime Synth, used by KDE),
148 PulseAudio (next generation GNOME sound server),
149 esd (EsounD or Enlightened Sound Daemon),
150 Mac OS X,
151 Windows (98 and later),
152 AIX,
153 Sun/NetBSD/OpenBSD,
154 IRIX,
155 NAS (Network Audio Server),
156 RoarAudio (Modern, multi-OS, networked Sound System),
157 OpenBSD's sndio.")
158 (license license:gpl2+)
159 (home-page "http://www.xiph.org/ao/")))
160
161 (define flac
162 (package
163 (name "flac")
164 (version "1.2.1")
165 (source (origin
166 (method url-fetch)
167 (uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
168 version ".tar.gz"))
169 (sha256
170 (base32
171 "1pry5lgzfg57pga1zbazzdd55fkgk3v5qy4axvrbny5lrr5s8dcn"))
172 (patches
173 (list (search-patch "flac-fix-memcmp-not-declared.patch")))))
174 (build-system gnu-build-system)
175 (arguments
176 `(#:parallel-tests? #f))
177 ;; FIXME: configure also looks for xmms, input could be added once it exists
178 (inputs `(("libogg" ,libogg)))
179 (synopsis "flac free lossless audio codec")
180 (description
181 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
182 meaning that audio is compressed in FLAC without any loss in quality.")
183 (license (license:bsd-style "file://COPYING"
184 "See COPYING in the distribution.")) ; and LGPL and GPL
185 (home-page "http://xiph.org/flac/")))
186
187 (define libkate
188 (package
189 (name "libkate")
190 (version "0.4.1")
191 (source (origin
192 (method url-fetch)
193 (uri (string-append "http://libkate.googlecode.com/files/libkate-"
194 version ".tar.gz"))
195 (sha256
196 (base32
197 "0s3vr2nxfxlf1k75iqpp4l78yf4gil3f0v778kvlngbchvaq23n4"))))
198 (build-system gnu-build-system)
199 ;; FIXME: Add optional inputs doxygen (for documentation) and liboggz
200 (inputs `(("bison" ,bison)
201 ("libogg" ,libogg)
202 ("libpng" ,libpng)
203 ("pkg-config" ,pkg-config)
204 ("python" ,python-wrapper)
205 ("zlib" ,zlib)))
206 (synopsis "kate, a karaoke and text codec for embedding in ogg")
207 (description
208 "Kate is an overlay codec, originally designed for karaoke and text,
209 that can be multiplixed in Ogg. Text and images can be carried by a Kate
210 stream, and animated. Most of the time, this would be multiplexed with
211 audio/video to carry subtitles, song lyrics (with or without karaoke data),
212 etc., but doesn't have to be.
213
214 Series of curves (splines, segments, etc.) may be attached to various
215 properties (text position, font size, etc.) to create animated overlays.
216 This allows scrolling or fading text to be defined. This can even be used
217 to draw arbitrary shapes, so hand drawing can also be represented by a
218 Kate stream.")
219 (license license:bsd-3)
220 (home-page "http://code.google.com/p/libkate/")))
221
222 (define vorbis-tools
223 (package
224 (name "vorbis-tools")
225 (version "1.4.0")
226 (source (origin
227 (method url-fetch)
228 (uri (string-append "http://downloads.xiph.org/releases/vorbis/vorbis-tools-"
229 version ".tar.gz"))
230 (sha256
231 (base32
232 "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))))
233 (build-system gnu-build-system)
234 (inputs `(("ao" ,ao)
235 ("curl" ,curl)
236 ("flac" ,flac)
237 ("libkate" ,libkate)
238 ("libogg" ,libogg)
239 ("libvorbis" ,libvorbis)
240 ("pkg-config" ,pkg-config)
241 ("speex" ,speex)))
242 (synopsis "ogg vorbis tools")
243 (description
244 "Ogg vorbis is a non-proprietary, patent-and-royalty-free,
245 general-purpose compressed audio format.
246
247 The package vorbis-tools contains
248 ogg123, an ogg vorbis command line audio player;
249 oggenc, the ogg vorbis encoder;
250 oggdec, a simple, portable command line decoder (to wav and raw);
251 ogginfo, to obtain information (tags, bitrate, length, etc.) about
252 an ogg vorbis file.")
253 (license license:gpl2)
254 (home-page "http://xiph.org/vorbis/")))