Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / nano.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages nano)
20 #:use-module (guix licenses)
21 #:use-module ((gnu packages gettext)
22 #:renamer (symbol-prefix-proc 'guix:))
23 #:use-module (gnu packages ncurses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public nano
29 (package
30 (name "nano")
31 (version "2.3.2")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/nano/nano-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "1s3b21h5p7r8xafw0gahswj16ai6k2vnjhmd15b491hl0x494c7z"))))
40 (build-system gnu-build-system)
41 (inputs
42 `(("gettext" ,guix:gettext)
43 ("ncurses" ,ncurses)))
44 (home-page "http://www.nano-editor.org/")
45 (synopsis "Small, user-friendly console text editor")
46 (description
47 "nano is a small and simple text editor. In addition to basic
48 editing, it supports interactive search and replace, go to line and column
49 number, auto-indentation and more.")
50 (license gpl3+))) ; some files are under GPLv2+