Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / mail.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mail)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages autotools)
22 #:use-module (gnu packages cyrus-sasl)
23 #:use-module (gnu packages dejagnu)
24 #:use-module (gnu packages gdbm)
25 #:use-module (gnu packages gnupg)
26 #:use-module (gnu packages gnutls)
27 #:use-module (gnu packages guile)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages m4)
30 #:use-module (gnu packages mysql)
31 #:use-module (gnu packages ncurses)
32 #:use-module (gnu packages openssl)
33 #:use-module (gnu packages perl)
34 #:use-module (gnu packages readline)
35 #:use-module (gnu packages texinfo)
36 #:use-module ((guix licenses)
37 #:select (gpl2+ gpl3+ lgpl3+))
38 #:use-module (guix packages)
39 #:use-module (guix download)
40 #:use-module (guix build-system gnu))
41
42 (define-public mailutils
43 (package
44 (name "mailutils")
45 (version "2.2")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append "mirror://gnu/mailutils/mailutils-"
49 version ".tar.bz2"))
50 (sha256
51 (base32
52 "0szbqa12zqzldqyw97lxqax3ja2adis83i7brdfsxmrfw68iaf65"))
53 (patches (list (search-patch "m4-gets-undeclared.patch")))))
54 (build-system gnu-build-system)
55 (arguments
56 '(;; TODO: Add `--with-sql'.
57 #:phases (alist-cons-before
58 'build 'pre-build
59 (lambda _
60 ;; Use Guile 2.0's public API.
61 (substitute* "libmu_scm/mu_message.c"
62 (("scm_i_string_length")
63 "scm_c_string_length"))
64
65 ;; This file should be generated to use the right
66 ;; value of $(libdir) et al.
67 (delete-file "libmu_scm/mailutils.scm")
68
69 ;; Use the right file name for `cat'.
70 (substitute* "testsuite/lib/mailutils.exp"
71 (("/bin/cat")
72 (which "cat"))))
73 %standard-phases)
74 #:parallel-tests? #f))
75 (inputs
76 `(("dejagnu" ,dejagnu)
77 ("m4" ,m4)
78 ("texinfo" ,texinfo)
79 ("guile" ,guile-2.0)
80 ("gnutls" ,gnutls)
81 ("ncurses" ,ncurses)
82 ("readline" ,readline)
83 ("linux-pam" ,linux-pam)
84 ("libtool" ,libtool)
85 ("gdbm" ,gdbm)))
86 (home-page "http://www.gnu.org/software/mailutils/")
87 (synopsis "Utilities and library for reading and serving mail")
88 (description
89 "Mailutils is a \"swiss army knife of electronic mail handling.\" It is
90 a suite of programs for managing, viewing and processing e-mail. It contains
91 both utilities and server daemons and all operate in a protocol-agnostic way.
92 The underlying libraries are also made available, making adding mail
93 capabilities to new software simple.")
94 (license
95 ;; Libraries are under LGPLv3+, and programs under GPLv3+.
96 (list gpl3+ lgpl3+))))
97
98 (define-public fetchmail
99 (package
100 (name "fetchmail")
101 (version "6.3.26")
102 (source (origin
103 (method url-fetch)
104 (uri (string-append "mirror://sourceforge/fetchmail/branch_6.3/fetchmail-"
105 version ".tar.xz"))
106 (sha256
107 (base32
108 "0l78ayvi9dm8hd190gl139cs2xqsrf7r9ncilslw20mgvd6cbd3r"))))
109 (build-system gnu-build-system)
110 (inputs
111 `(("openssl" ,openssl)))
112 (arguments
113 `(#:configure-flags (list (string-append "--with-ssl="
114 (assoc-ref %build-inputs "openssl")))))
115 (home-page "http://fetchmail.berlios.de/")
116 (synopsis "Remote-mailr etrieval and forwarding utility")
117 (description
118 "Fetchmail is a full-featured, robust, well-documented remote-mail
119 retrieval and forwarding utility intended to be used over on-demand
120 TCP/IP links (such as SLIP or PPP connections). It supports every
121 remote-mail protocol now in use on the Internet: POP2, POP3, RPOP, APOP,
122 KPOP, all flavors of IMAP, ETRN, and ODMR. It can even support IPv6
123 and IPSEC.
124
125 Fetchmail retrieves mail from remote mail servers and forwards it via SMTP,
126 so it can then be read by normal mail user agents such as mutt, elm
127 or BSD Mail. It allows all your system MTA's filtering, forwarding, and
128 aliasing facilities to work just as they would on normal mail.")
129 (license gpl2+))) ; most files are actually public domain or x11
130
131 (define-public mutt
132 (package
133 (name "mutt")
134 (version "1.5.21")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "ftp://ftp.mutt.org/mutt/devel/mutt-"
138 version ".tar.gz"))
139 (sha256
140 (base32
141 "1864cwz240gh0zy56fb47qqzwyf6ghg01037rb4p2kqgimpg6h91"))))
142 (build-system gnu-build-system)
143 (inputs
144 `(("cyrus-sasl" ,cyrus-sasl)
145 ("gpgme" ,gpgme)
146 ("ncurses" ,ncurses)
147 ("openssl" ,openssl)
148 ("perl" ,perl)))
149 (arguments
150 `(#:configure-flags '("--enable-smtp"
151 "--enable-imap"
152 "--enable-pop"
153 "--enable-gpgme"
154 "--with-ssl"
155 "--with-sasl"
156 ;; so that mutt does not check whether the path
157 ;; exists, which it does not in the chroot
158 "--with-mailpath=/var/mail")))
159 (home-page "http://www.mutt.org/")
160 (synopsis "Mail client")
161 (description
162 "Mutt is a small but very powerful text-based mail client for Unix
163 operating systems.")
164 (license gpl2+)))