Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / m4.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages m4)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public m4
27 (package
28 (name "m4")
29 (version "1.4.17")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/m4/m4-"
33 version ".tar.bz2"))
34 (sha256
35 (base32
36 "0w0da1chh12mczxa5lnwzjk9czi3dq6gnnndbpa6w4rj76b1yklf"))))
37 (build-system gnu-build-system)
38 (arguments
39 ;; XXX: Disable tests on those platforms with know issues.
40 `(#:tests? ,(not (member (%current-system)
41 '("x86_64-darwin"
42 "i686-cygwin"
43 "i686-sunos")))
44 #:patches (list (assoc-ref %build-inputs
45 "patch/readlink-EINVAL"))
46 #:phases (alist-cons-before
47 'check 'pre-check
48 (lambda* (#:key inputs #:allow-other-keys)
49 ;; Fix references to /bin/sh.
50 (let ((bash (assoc-ref inputs "bash")))
51 (for-each patch-shebang
52 (find-files "tests" "\\.sh$"))
53 (substitute* (find-files "tests"
54 "posix_spawn")
55 (("/bin/sh")
56 (format #f "~a/bin/bash" bash)))))
57 %standard-phases)))
58 (inputs `(("patch/readlink-EINVAL"
59 ,(search-patch "m4-readlink-EINVAL.patch"))))
60 (synopsis "Macro processor")
61 (description
62 "GNU M4 is an implementation of the M4 macro language, which features
63 some extensions over other implementations. It is used as a macro processor,
64 which means it processes text, expanding macros as it encounters them. It
65 also has some built-in functionns, for example to run shell commands or to do
66 arithmetic.")
67 (license gpl3+)
68 (home-page "http://www.gnu.org/software/m4/")))