Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / indent.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages indent)
20 #:use-module (gnu packages)
21 #:use-module ((guix licenses)
22 #:renamer (symbol-prefix-proc 'license:))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public indent
28 (package
29 (name "indent")
30 (version "2.2.10")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/indent/indent-" version
34 ".tar.gz"))
35 (sha256 (base32
36 "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
37 (build-system gnu-build-system)
38 (synopsis "Code reformatter")
39 (description
40 "Indent is a program that makes source code easier to read by
41 reformatting it in a consistetn style. It can change the style to one of
42 several different styles such as GNU, BSD or K&R. It has some flexibility to
43 deal with incomplete or malformed syntax.")
44 (license license:gpl3+)
45 (home-page "http://www.gnu.org/software/indent/")))