Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / idutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages idutils)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages))
25
26 (define-public idutils
27 (package
28 (name "idutils")
29 (version "4.6")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/idutils/idutils-"
33 version ".tar.xz"))
34 (sha256
35 (base32
36 "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1"))
37 (patches (list
38 (search-patch "diffutils-gets-undeclared.patch")))))
39 (build-system gnu-build-system)
40 (inputs `(;; TODO: Add Emacs as an input for byte-compilation.
41 ;; ("emacs" ,emacs)
42 ))
43 (home-page "http://www.gnu.org/software/idutils/")
44 (synopsis "Identifier database utilities")
45 (description
46 "ID Utils provides tools to create an index if textual tokens used in a
47 list of file names and to then query that index. Thus, it allows the user
48 to, for example, find all the uses of a particular function in all files of a
49 large programming project. In addition to handling textual tokens, it can
50 also handle numeric constants and the contents of character strings.")
51 (license gpl3+)))