Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / help2man.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages help2man)
20 #:use-module (guix licenses)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages perl))
25
26 (define-public help2man
27 (package
28 (name "help2man")
29 (version "1.43.3")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/help2man/help2man-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "00yk86rvvaavg7y6i5bvk5xhm417jl9dpr8bqvqdksw0i48qv5v7"))))
38 (build-system gnu-build-system)
39 (arguments `(;; There's no `check' target.
40 #:tests? #f))
41 (inputs
42 `(("perl" ,perl)
43 ;; TODO: Add these optional dependencies.
44 ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
45 ;; ("gettext" ,gettext)
46 ))
47 (home-page "http://www.gnu.org/software/help2man/")
48 (synopsis "Automatically generate man pages from program --help")
49 (description
50 "help2man is a program that converts the output of standard \"--help\"
51 and \"--version\" command-line arguments into a manual page automatically.")
52 (license gpl3+)))