Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gsasl)
20 #:use-module (gnu packages)
21 #:use-module ((gnu packages compression)
22 #:renamer (symbol-prefix-proc 'guix:))
23 #:use-module (gnu packages gnutls)
24 #:use-module (gnu packages libidn)
25 #:use-module (gnu packages nettle)
26 #:use-module (gnu packages shishi)
27 #:use-module (guix licenses)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu))
31
32 (define-public libntlm
33 (package
34 (name "libntlm")
35 (version "1.3")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "http://www.nongnu.org/libntlm/releases/libntlm-" version
39 ".tar.gz"))
40 (sha256 (base32
41 "101pr110ardcj2di940g6vaqifsaxc44h6hjn81l63dvmkj5a6ga"))))
42 (build-system gnu-build-system)
43 (synopsis "Libntlm, a library that implements NTLM authentication")
44 (description
45 "Libntlm is a library that implements NTLM authentication")
46 (license lgpl2.1+)
47 (home-page "http://www.nongnu.org/libntlm/")))
48
49 (define-public gss
50 (package
51 (name "gss")
52 (version "1.0.2")
53 (source (origin
54 (method url-fetch)
55 (uri (string-append "mirror://gnu/gss/gss-" version
56 ".tar.gz"))
57 (sha256 (base32
58 "1qa8lbkzi6ilfggx7mchfzjnchvhwi68rck3jf9j4425ncz7zsd9"))))
59 (build-system gnu-build-system)
60 (inputs `(("nettle" ,nettle)
61 ("shishi" ,shishi)
62 ("zlib" ,guix:zlib)
63 ))
64 (synopsis "Generic Security Service library")
65 (description
66 "The GNU Generic Security Service provides a free implementation of the
67 GSS-API specification. It provides a generic application programming
68 interface for programs to access security services. Security services present
69 a generic, GSS interface, with which the calling application interacts via
70 this library, freeing the application developer from needing to know about
71 the underlying security implementation.")
72 (license gpl3+)
73 (home-page "http://www.gnu.org/software/gss/")))
74
75 (define-public gsasl
76 (package
77 (name "gsasl")
78 (version "1.8.0")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append "mirror://gnu/gsasl/gsasl-" version
82 ".tar.gz"))
83 (sha256 (base32
84 "1rci64cxvcfr8xcjpqc4inpfq7aw4snnsbf5xz7d30nhvv8n40ii"))))
85 (build-system gnu-build-system)
86 (inputs `(("libidn" ,libidn)
87 ("libntlm" ,libntlm)
88 ("gss" ,gss)
89 ("zlib" ,guix:zlib)))
90 (propagated-inputs
91 ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
92 ;; propagated input of GnuTLS.
93 `(("gnutls" ,gnutls)))
94 (synopsis "Simple Authentication and Security Layer library")
95 (description
96 "GNU SASL is an implementation of the Simple Authentication and
97 Security Layer framework. On network servers such as IMAP or SMTP servers,
98 SASL is used to handle client/server authentication. This package contains
99 both a library and a command-line tool to access the library.")
100 (license gpl3+)
101 (home-page "http://www.gnu.org/software/gsasl/")))