Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / gprolog.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gprolog)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public gprolog
27 (package
28 (name "gprolog")
29 (version "1.4.4")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/gprolog/gprolog-" version
34 ".tar.gz"))
35 (sha256
36 (base32
37 "13miyas47bmijmadm68cbvb21n4s156gjafz7kfx9brk9djfkh0q"))))
38 (build-system gnu-build-system)
39 (arguments
40 `(#:phases (alist-cons-before
41 'configure 'change-dir-n-fix-shells
42 (lambda _
43 (chdir "src")
44 (substitute* "configure"
45 (("-/bin/sh") (string-append "-" (which "sh")))
46 (("= /bin/sh") (string-append "= " (which "sh")))))
47 %standard-phases)))
48 (home-page "https://www.gnu.org/software/gprolog/")
49 (synopsis "Prolog compiler")
50 (description
51 "GNU Prolog is a standards-compliant Prolog compiler with constraint
52 solving over finite domains. It accepts Prolog+ constraint programs and
53 produces a compiled, native binary which can function in a stand- alone
54 manner. It also features an interactive interpreter.")
55 (license (list gpl2+ lgpl3+))))