Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / gnupg.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gnupg)
21 #:use-module (guix licenses)
22 #:use-module (gnu packages curl)
23 #:use-module (gnu packages openldap)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages pth)
26 #:use-module (gnu packages python)
27 #:use-module (gnu packages readline)
28 #:use-module ((gnu packages compression)
29 #:renamer (symbol-prefix-proc 'guix:))
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public libgpg-error
35 (package
36 (name "libgpg-error")
37 (version "1.12")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnupg/libgpg-error/libgpg-error-"
42 version ".tar.bz2"))
43 (sha256
44 (base32
45 "0pz58vr12qihq2f0bypjxsb6cf6ajq5258fmfm8s6lvwm3b9xz6a"))))
46 (build-system gnu-build-system)
47 (home-page "http://gnupg.org")
48 (synopsis
49 "Libgpg-error, a small library that defines common error values for all GnuPG components")
50 (description
51 "Libgpg-error is a small library that defines common error values
52 for all GnuPG components. Among these are GPG, GPGSM, GPGME,
53 GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard
54 Daemon and possibly more in the future.")
55 (license lgpl2.0+)))
56
57 (define-public libgcrypt
58 (package
59 (name "libgcrypt")
60 (version "1.5.3")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
64 version ".tar.bz2"))
65 (sha256
66 (base32
67 "1lar8y3lh61zl5flljpz540d78g99h4d5idfwrfw8lm3gm737xdw"))))
68 (build-system gnu-build-system)
69 (propagated-inputs
70 `(("libgpg-error" ,libgpg-error)))
71 (home-page "http://gnupg.org/")
72 (synopsis "Cryptographic function library")
73 (description
74 "Libgcrypt is a general-purpose cryptographic library. It provides the
75 standard cryptographic building blocks such as symmetric ciphers, hash
76 algorithms, public key algorithms, large integer functions and random number
77 generation.")
78 (license lgpl2.0+)))
79
80 (define-public libassuan
81 (package
82 (name "libassuan")
83 (version "2.1.1")
84 (source
85 (origin
86 (method url-fetch)
87 (uri (string-append "mirror://gnupg/libassuan/libassuan-"
88 version ".tar.bz2"))
89 (sha256
90 (base32
91 "1783nb0b6nr9yjhb5wfh8ykc5w89f4anppz1kz9913mqg5vxdqi3"))))
92 (build-system gnu-build-system)
93 (propagated-inputs
94 `(("libgpg-error" ,libgpg-error) ("pth" ,pth)))
95 (home-page "http://gnupg.org")
96 (synopsis
97 "Libassuan, the IPC library used by GnuPG and related software")
98 (description
99 "Libassuan is a small library implementing the so-called Assuan
100 protocol. This protocol is used for IPC between most newer
101 GnuPG components. Both, server and client side functions are
102 provided.")
103 (license lgpl2.0+)))
104
105 (define-public libksba
106 (package
107 (name "libksba")
108 (version "1.3.0")
109 (source
110 (origin
111 (method url-fetch)
112 (uri (string-append
113 "mirror://gnupg/libksba/libksba-"
114 version ".tar.bz2"))
115 (sha256
116 (base32
117 "0w8rfb6yhcwkwzvjafrashcygy4hd9xwwmvlnkfd1m2h0paywqas"))))
118 (build-system gnu-build-system)
119 (propagated-inputs
120 `(("libgpg-error" ,libgpg-error)))
121 (home-page "http://www.gnupg.org")
122 (synopsis
123 "Libksba is a CMS and X.509 access library under development")
124 (description
125 "KSBA (pronounced Kasbah) is a library to make X.509 certificates
126 as well as the CMS easily accessible by other applications. Both
127 specifications are building blocks of S/MIME and TLS.")
128 (license gpl3+)))
129
130 (define-public gnupg
131 (package
132 (name "gnupg")
133 (version "2.0.22")
134 (source
135 (origin
136 (method url-fetch)
137 (uri (string-append "mirror://gnupg/gnupg/gnupg-" version
138 ".tar.bz2"))
139 (sha256
140 (base32
141 "0lg210acj2rxq291q4cwamg9gx6gh2prb1xa93y5jhw5b6r0lza3"))))
142 (build-system gnu-build-system)
143 (inputs
144 `(("bzip2" ,guix:bzip2)
145 ("curl" ,curl)
146 ("libassuan" ,libassuan)
147 ("libgcrypt" ,libgcrypt)
148 ("libgpg-error" ,libgpg-error)
149 ("libksba" ,libksba)
150 ("pth" ,pth)
151 ("openldap" ,openldap)
152 ("zlib" ,guix:zlib)
153 ("readline" ,readline)))
154 (arguments
155 `(#:phases
156 (alist-replace
157 'configure
158 (lambda* (#:key #:allow-other-keys #:rest args)
159 (let ((configure (assoc-ref %standard-phases 'configure)))
160 (substitute* "tests/openpgp/Makefile.in"
161 (("/bin/sh") (which "bash")))
162 (apply configure args)))
163 %standard-phases)))
164 (home-page "http://gnupg.org/")
165 (synopsis "GNU Privacy Guard")
166 (description
167 "The GNU Privacy Guard is a complete implementation of the OpenPGP
168 standard. It is used to encrypt and sign data and communication. It
169 features powerful key management and the ability to access public key
170 servers.")
171 (license gpl3+)))
172
173 (define-public gpgme
174 (package
175 (name "gpgme")
176 (version "1.4.3")
177 (source
178 (origin
179 (method url-fetch)
180 (uri (string-append "mirror://gnupg/gpgme/gpgme-" version
181 ".tar.bz2"))
182 (sha256
183 (base32
184 "15h429h6pd67iiv580bjmwbkadpxsdppw0xrqpcm4dvm24jc271d"))))
185 (build-system gnu-build-system)
186 (inputs
187 `(("gnupg" ,gnupg)
188 ("libassuan" ,libassuan)
189 ("libgpg-error" ,libgpg-error)))
190 (home-page "http://www.gnupg.org/related_software/gpgme/")
191 (synopsis "library providing simplified access to GnuPG functionality")
192 (description
193 "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG
194 easier for applications. It provides a High-Level Crypto API for encryption,
195 decryption, signing, signature verification and key management. Currently
196 it uses GnuPG as its backend but the API isn't restricted to this engine.
197
198 Because the direct use of GnuPG from an application can be a complicated
199 programming task, it is suggested that all software should try to use GPGME
200 instead. This way bug fixes or improvements can be done at a central place
201 and every application benefits from this.")
202 (license lgpl2.1+)))
203
204 (define-public pius
205 (package
206 (name "pius")
207 (version "2.0.9")
208 (source (origin
209 (method url-fetch)
210 (uri (string-append "mirror://sourceforge/pgpius/pius/"
211 version "/pius-"
212 version ".tar.bz2"))
213 (sha256 (base32
214 "1g1jly3wl4ks6h8ydkygyl2c4i7v3z91rg42005m6vm70y1d8b3d"))))
215 (build-system gnu-build-system)
216 (inputs `(("perl" ,perl)
217 ("python" ,python-wrapper)
218 ("gpg" ,gnupg)))
219 (arguments
220 `(#:tests? #f
221 #:phases
222 (alist-replace
223 'configure
224 (lambda* (#:key #:allow-other-keys) #t)
225 (alist-replace
226 'build
227 (lambda* (#:key #:allow-other-keys) #t)
228 (alist-replace
229 'install
230 (lambda* (#:key inputs outputs #:allow-other-keys)
231 (let* ((out (assoc-ref outputs "out"))
232 (gpg (string-append (assoc-ref inputs "gpg")
233 "/bin/gpg2")))
234 (mkdir out)
235 (mkdir (string-append out "/bin"))
236 (for-each (lambda (file)
237 (substitute* file
238 (("/usr/bin/gpg") gpg))
239 (copy-file file (string-append out "/bin/" file)))
240 '("pius" "pius-keyring-mgr" "pius-party-worksheet"))))
241 %standard-phases)))))
242 (synopsis "Programs to simplify GnuPG key signing")
243 (description
244 "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
245 parties. It is the main utility and makes it possible to quickly and easily
246 sign each UID on a set of PGP keys. It is designed to take the pain out of
247 the sign-all-the-keys part of PGP Keysigning Party while adding security
248 to the process.
249
250 pius-keyring-mgr and pius-party-worksheet help organisers of
251 PGP keysigning parties.")
252 (license gpl2)
253 (home-page "http://www.phildev.net/pius/index.shtml")))
254
255 (define-public signing-party
256 (package
257 (name "signing-party")
258 (version "1.1.4")
259 (source (origin
260 (method url-fetch)
261 (uri (string-append "http://ftp.debian.org/debian/pool/main/s/signing-party/signing-party_"
262 version ".orig.tar.gz"))
263 (sha256 (base32
264 "188gp0prbh8qs29lq3pbf0qibfd6jq4fk7i0pfrybl8aahvm84rx"))))
265 (build-system gnu-build-system)
266 (inputs `(("perl" ,perl)))
267 (arguments
268 `(#:tests? #f
269 #:phases
270 (alist-replace
271 'unpack
272 (lambda* (#:key #:allow-other-keys #:rest args)
273 (let ((unpack (assoc-ref %standard-phases 'unpack)))
274 (apply unpack args)
275 ;; remove spurious symlink
276 (delete-file "keyanalyze/pgpring/depcomp")))
277 (alist-replace
278 'configure
279 (lambda* (#:key outputs #:allow-other-keys)
280 (let ((out (assoc-ref outputs "out")))
281 (substitute* "keyanalyze/Makefile"
282 (("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
283 (substitute* "keyanalyze/Makefile"
284 (("./configure") (string-append "./configure --prefix=" out)))
285 (substitute* "keyanalyze/pgpring/configure"
286 (("/bin/sh") (which "bash")))
287 (substitute* "gpgwrap/Makefile"
288 (("\\} clean") (string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
289 out "/bin/gpgwrap\n")))
290 (substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
291 "keylookup/Makefile" "sig2dot/Makefile"
292 "springgraph/Makefile")
293 (("/usr") out))))
294 (alist-replace
295 'install
296 (lambda* (#:key outputs #:allow-other-keys #:rest args)
297 (let ((out (assoc-ref outputs "out"))
298 (install (assoc-ref %standard-phases 'install)))
299 (apply install args)
300 (for-each
301 (lambda (dir file)
302 (copy-file (string-append dir "/" file)
303 (string-append out "/bin/" file)))
304 '("caff" "caff" "caff" "gpgdir" "gpg-key2ps"
305 "gpglist" "gpg-mailkeys" "gpgparticipants")
306 '("caff" "pgp-clean" "pgp-fixkey" "gpgdir" "gpg-key2ps"
307 "gpglist" "gpg-mailkeys" "gpgparticipants"))
308 (for-each
309 (lambda (dir file)
310 (copy-file (string-append dir "/" file)
311 (string-append out "/share/man/man1/" file)))
312 '("caff" "caff" "caff" "gpgdir"
313 "gpg-key2ps" "gpglist" "gpg-mailkeys"
314 "gpgparticipants" "gpgsigs" "gpgwrap/doc"
315 "keyanalyze" "keyanalyze/pgpring" "keyanalyze")
316 '("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
317 "gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
318 "gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
319 "process_keys.1" "pgpring.1" "keyanalyze.1"))))
320 %standard-phases)))))
321 (synopsis "collection of scripts for simplifying gnupg key signing")
322 (description
323 "signing-party is a collection for all kinds of PGP/GnuPG related things,
324 including tools for signing keys, keyring analysis, and party preparation.
325
326 * caff: CA - Fire and Forget signs and mails a key
327
328 * pgp-clean: removes all non-self signatures from key
329
330 * pgp-fixkey: removes broken packets from keys
331
332 * gpg-mailkeys: simply mail out a signed key to its owner
333
334 * gpg-key2ps: generate PostScript file with fingerprint paper strips
335
336 * gpgdir: recursive directory encryption tool
337
338 * gpglist: show who signed which of your UIDs
339
340 * gpgsigs: annotates list of GnuPG keys with already done signatures
341
342 * gpgparticipants: create list of party participants for the organiser
343
344 * gpgwrap: a passphrase wrapper
345
346 * keyanalyze: minimum signing distance (MSD) analysis on keyrings
347
348 * keylookup: ncurses wrapper around gpg --search
349
350 * sig2dot: converts a list of GnuPG signatures to a .dot file
351
352 * springgraph: creates a graph from a .dot file")
353 ;; gpl2+ for almost all programs, except for keyanalyze: gpl2
354 ;; and caff and gpgsigs: bsd-3, see
355 ;; http://packages.debian.org/changelogs/pool/main/s/signing-party/current/copyright
356 (license gpl2)
357 (home-page "http://pgp-tools.alioth.debian.org/")))