Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / emacs.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages emacs)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gtk)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages texinfo)
28 #:use-module (gnu packages gnutls)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages guile)
31 #:use-module (gnu packages xorg)
32 #:use-module (gnu packages lesstif)
33 #:use-module (gnu packages libjpeg)
34 #:use-module (gnu packages libtiff)
35 #:use-module (gnu packages libpng)
36 #:use-module ((gnu packages compression)
37 #:renamer (symbol-prefix-proc 'compression:))
38 #:use-module (gnu packages xml)
39 #:use-module (gnu packages glib))
40
41 (define-public emacs
42 (package
43 (name "emacs")
44 (version "24.3")
45 (source (origin
46 (method url-fetch)
47 (uri (string-append "mirror://gnu/emacs/emacs-"
48 version ".tar.xz"))
49 (sha256
50 (base32
51 "1385qzs3bsa52s5rcncbrkxlydkw0ajzrvfxgv8rws5fx512kakh"))
52 (patches (list (search-patch "emacs-configure-sh.patch")))))
53 (build-system gnu-build-system)
54 (arguments
55 '(#:configure-flags
56 (list (string-append "--with-crt-dir=" (assoc-ref %build-inputs "libc")
57 "/lib")
58 "--with-gif=no") ; XXX: add libungif
59 #:phases (alist-cons-before
60 'configure 'fix-/bin/pwd
61 (lambda _
62 ;; Use `pwd', not `/bin/pwd'.
63 (substitute* (find-files "." "^Makefile\\.in$")
64 (("/bin/pwd")
65 "pwd")))
66 %standard-phases)))
67 (inputs
68 `(("pkg-config" ,pkg-config)
69 ("gnutls" ,gnutls)
70 ("texinfo" ,texinfo)
71 ("ncurses" ,ncurses)
72
73 ;; TODO: Add the optional dependencies.
74 ("xlibs" ,libx11)
75 ("gtk+" ,gtk+-2)
76 ("libXft" ,libxft)
77 ("libtiff" ,libtiff)
78 ;; ("libungif" ,libungif)
79 ("libjpeg" ,libjpeg-8)
80
81 ;; When looking for libpng `configure' links with `-lpng -lz', so we
82 ;; must also provide zlib as an input.
83 ("libpng" ,libpng)
84 ("zlib" ,compression:zlib)
85
86 ("libXpm" ,libxpm)
87 ("libxml2" ,libxml2)
88 ("dbus" ,dbus)))
89 (home-page "http://www.gnu.org/software/emacs/")
90 (synopsis "The extensible, customizable, self-documenting text editor")
91 (description
92 "Emacs is an extensible and highly customizable text editor. It is
93 based on an Emacs Lisp interpreter which has extensions to support text
94 editing. Due to its unique structure, it can be configured in an infinite
95 multitude of ways, which has given rise to a vast array of packages that have
96 been written for it that do everything from working as an email client to
97 communicating online via IRC or XMPP. Emacs is fully self-documenting and it
98 features full Unicode support for nearly every human language.")
99 (license gpl3+)))
100
101 \f
102 ;;;
103 ;;; Emacs hacking.
104 ;;;
105
106 (define-public geiser
107 (package
108 (name "geiser")
109 (version "0.4")
110 (source (origin
111 (method url-fetch)
112 (uri (string-append "mirror://savannah/geiser/" version
113 "/geiser-" version ".tar.gz"))
114 (sha256
115 (base32 "0ds7zk9b1839l9fsqfsgrby6manvy1cf5bjniiqhxl55h0cr6ijp"))))
116 (build-system gnu-build-system)
117 (inputs `(("guile" ,guile-2.0)
118 ("emacs" ,emacs)))
119 (home-page "http://nongnu.org/geiser/")
120 (synopsis "Collection of Emacs modes for Guile and Racket hacking")
121 (description
122 "Geiser is a collection of Emacs major and minor modes that
123 conspire with one or more Scheme interpreters to keep the Lisp Machine
124 Spirit alive. It draws inspiration (and a bit more) from environments
125 such as Common Lisp’s Slime, Factor’s FUEL, Squeak or Emacs itself, and
126 does its best to make Scheme hacking inside Emacs (even more) fun.
127
128 Or, to be precise, what i consider fun. Geiser is thus my humble
129 contribution to the dynamic school of expression, and a reaction against
130 what i perceive as a derailment, in modern times, of standard Scheme
131 towards the static camp. Because i prefer growing and healing to poking
132 at corpses, the continuously running Scheme interpreter takes the center
133 of the stage in Geiser. A bundle of Elisp shims orchestrates the dialog
134 between the Scheme interpreter, Emacs and, ultimately, the schemer,
135 giving her access to live metadata.")
136 (license bsd-3)))