gnu: apl: Add pcre support.
[jackhill/guix/guix.git] / gnu / packages / apl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages apl)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages maths)
28 #:use-module (gnu packages pcre)
29 #:use-module (gnu packages readline)
30 #:use-module (gnu packages sqlite))
31
32 (define-public apl
33 (package
34 (name "apl")
35 (version "1.8")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
40 (sha256
41 (base32
42 "1jxvv2h3y1am1fw6r5sn3say1n0dj8shmscbybl0qhqdia2lqkql"))))
43 (build-system gnu-build-system)
44 (home-page "https://www.gnu.org/software/apl/")
45 (inputs
46 `(("gettext" ,gettext-minimal)
47 ("lapack" ,lapack)
48 ("pcre" ,pcre2)
49 ("sqlite" ,sqlite)
50 ("readline" ,readline)))
51 (arguments
52 `(#:configure-flags (list (string-append
53 "--with-sqlite3="
54 (assoc-ref %build-inputs "sqlite")))))
55 (synopsis "APL interpreter")
56 (description
57 "GNU APL is a free interpreter for the programming language APL. It is
58 an implementation of the ISO standard 13751.")
59 (license gpl3+)))