gnu: perl-www-curl: Fix build failure.
[jackhill/guix/guix.git] / gnu / packages / patches / perl-www-curl-remove-symbol.patch
1 Fix build failure caused by erroneous use of an undeclared symbol.
2
3 Patch copied from upstream bug report:
4 https://rt.cpan.org/Public/Bug/Display.html?id=117793
5
6 From 0be0223422e6e5f4091c6e4e058d213623eed105 Mon Sep 17 00:00:00 2001
7 From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
8 Date: Mon, 12 Sep 2016 14:40:44 +0200
9 Subject: [PATCH] Skip preprocessor symbol only CURL_STRICTER
10 MIME-Version: 1.0
11 Content-Type: text/plain; charset=UTF-8
12 Content-Transfer-Encoding: 8bit
13
14 CURL_STRICTER leaked into curl-constants.c when building against
15 curl-7.50.2. This is a preprocessor only macro without a value.
16
17 CPAN RT#117793
18
19 Signed-off-by: Petr Písař <ppisar@redhat.com>
20 ---
21 Makefile.PL | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24 diff --git a/Makefile.PL b/Makefile.PL
25 index f9170bb..ad2bd3d 100644
26 --- a/Makefile.PL
27 +++ b/Makefile.PL
28 @@ -127,7 +127,7 @@ if (!defined($curl_h)) {
29 close H;
30
31 for my $e (sort @syms) {
32 - if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
33 + if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|_LAST\z|_LASTENTRY\z)/) {
34 next;
35 }
36 my ($group) = $e =~ m/^([^_]+_)/;
37 --
38 2.7.4
39