gnu: perl-www-curl: Fix build failure.
[jackhill/guix/guix.git] / gnu / packages / irc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
4 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages irc)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix download)
26 #:use-module (guix packages)
27 #:use-module (guix build-system cmake)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system python)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages aspell)
32 #:use-module (gnu packages autogen)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages base)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages cyrus-sasl)
38 #:use-module (gnu packages file)
39 #:use-module (gnu packages gettext)
40 #:use-module (gnu packages glib)
41 #:use-module (gnu packages gnupg)
42 #:use-module (gnu packages guile)
43 #:use-module (gnu packages lua)
44 #:use-module (gnu packages ncurses)
45 #:use-module (gnu packages kde)
46 #:use-module (gnu packages kde-frameworks)
47 #:use-module (gnu packages perl)
48 #:use-module (gnu packages pkg-config)
49 #:use-module (gnu packages python)
50 #:use-module (gnu packages qt)
51 #:use-module (gnu packages tcl)
52 #:use-module (gnu packages tls)
53 #:use-module (gnu packages web))
54
55 (define-public quassel
56 (package
57 (name "quassel")
58 (version "0.12.4")
59 (source
60 (origin
61 (method url-fetch)
62 (uri (string-append "http://quassel-irc.org/pub/quassel-"
63 version ".tar.bz2"))
64 (sha256
65 (base32
66 "0ka456fb8ha3w7g74xlzfg6w4azxjjxgrhl4aqpbwg3lnd6fbr4k"))))
67 (build-system cmake-build-system)
68 (arguments
69 ;; The three binaries are not mutually exlusive, and are all built
70 ;; by default.
71 `(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.0 MiB
72 ;;"-DWANT_CORE=OFF" ; 2.3 MiB
73 ;;"-DWANT_MONO=OFF" ; 6.3 MiB
74 "-DUSE_QT5=ON" ; default is qt4
75 "-DWITH_KDE=OFF" ; no to integration
76 "-DWITH_OXYGEN=ON" ; on=embed icons
77 "-DWITH_WEBKIT=OFF") ; qtwebkit isn't packaged
78 #:tests? #f)) ; no test target
79 (native-inputs `(("pkg-config" ,pkg-config)))
80 (inputs
81 `(("extra-cmake-modules" ,extra-cmake-modules)
82 ("oxygen-icons" ,oxygen-icons)
83 ("qca" ,qca)
84 ("qtbase", qtbase)
85 ("qttools" ,qttools)
86 ("qtscript" ,qtscript)
87 ("snorenotify" ,snorenotify)
88 ("zlib" ,zlib)))
89 (home-page "http://quassel-irc.org/")
90 (synopsis "Distributed IRC client")
91 (description "Quassel is a distributed IRC client, meaning that one or more
92 clients can attach to and detach from the central core. It resembles the
93 popular combination of screen and a text-based IRC client such as WeeChat or
94 irssi, but graphical.")
95 (license (list license:gpl2 license:gpl3)))) ;; dual licensed
96
97 (define-public irssi
98 (package
99 (name "irssi")
100 (version "0.8.20")
101 (source (origin
102 (method url-fetch)
103 (uri (string-append "https://github.com/irssi/irssi/"
104 "releases/download/" version "/irssi-"
105 version ".tar.xz"))
106 (sha256
107 (base32
108 "0njh43xmpad9h5g6fp1805hrix1mwbbnk7p6qmlw9apm47lc90kq"))))
109 (build-system gnu-build-system)
110 (arguments
111 `(#:phases
112 (modify-phases %standard-phases
113 (replace 'configure
114 (lambda* (#:key inputs outputs #:allow-other-keys)
115 (let ((out (assoc-ref outputs "out"))
116 (ncurses (assoc-ref inputs "ncurses")))
117 (setenv "CONFIG_SHELL" (which "bash"))
118 (zero?
119 (system* "./configure"
120 (string-append "--prefix=" out)
121 (string-append "--with-ncurses=" ncurses)
122 (string-append "--with-proxy")
123 (string-append "--with-socks")
124 (string-append "--with-bot")))))))))
125 (inputs
126 `(("glib" ,glib)
127 ("ncurses" ,ncurses)
128 ("openssl" ,openssl)))
129 (native-inputs
130 `(("pkg-config" ,pkg-config)
131 ("perl" ,perl)))
132 (home-page "http://www.irssi.org/")
133 (synopsis "Terminal-based IRC client")
134 (description
135 "Irssi is a terminal based IRC client for UNIX systems. It also supports
136 SILC and ICB protocols via plugins.")
137 (license license:gpl2+)))
138
139 (define-public weechat
140 (package
141 (name "weechat")
142 (version "1.5")
143 (source (origin
144 (method url-fetch)
145 (uri (string-append "http://weechat.org/files/src/weechat-"
146 version ".tar.gz"))
147 (sha256
148 (base32
149 "0w87w4wy61x705ama8h36z9mgdj2gmmzdfrsxvwyh2m2as2max1i"))
150 (patches (search-patches "weechat-python.patch"))))
151 (build-system gnu-build-system)
152 (native-inputs `(("autoconf" ,autoconf)
153 ("pkg-config" ,pkg-config)
154 ("file" ,file)
155 ("autogen" ,autogen)
156 ("automake" ,automake)
157 ("libtool" ,libtool)))
158 (inputs `(("ncurses" ,ncurses)
159 ("diffutils" ,diffutils)
160 ("gettext" ,gettext-minimal)
161 ("libltdl" ,libltdl)
162 ("libgcrypt" ,libgcrypt "out")
163 ("zlib" ,zlib)
164 ("aspell" ,aspell)
165 ("curl" ,curl)
166 ("gnutls" ,gnutls)
167 ("guile" ,guile-2.0)
168 ("openssl" ,openssl)
169 ("cyrus-sasl" ,cyrus-sasl)
170 ("lua" ,lua-5.1)
171 ("python" ,python-2)
172 ("perl" ,perl)
173 ("tcl" ,tcl)))
174 (arguments
175 `(#:configure-flags (list (string-append
176 "--with-tclconfig="
177 (assoc-ref %build-inputs "tcl") "/lib"))
178 #:phases (modify-phases %standard-phases
179 (add-before 'configure 'autogen
180 (lambda _
181 (zero? (system* "./autogen.sh"))))
182 (add-before 'build 'set-python-file-name
183 (lambda* (#:key inputs #:allow-other-keys)
184 (substitute* "src/plugins/python/weechat-python.c"
185 (("python2_bin = weechat_python_get_python2_bin.*;")
186 (string-append "python2_bin = strdup (\""
187 (assoc-ref inputs "python")
188 "/bin/python\");\n")))
189 #t)))))
190 (synopsis "Extensible chat client")
191 (description "WeeChat (Wee Enhanced Environment for Chat) is an
192 Internet Relay Chat client, which is designed to be light and fast.
193 The client uses a curses frontend, and there are remote interfaces
194 for Web, Qt, Android and Emacs. In WeeChat everything can be done
195 with a keyboard, though it also supports mouse. It is customizable
196 and extensible with plugins and scripts.")
197 (home-page "http://www.weechat.org/")
198 (license license:gpl3)))
199
200 (define-public ircii
201 (package
202 (name "ircii")
203 (version "20151120")
204 (source (origin
205 (method url-fetch)
206 (uri (string-append "https://ircii.warped.com/"
207 name "-" version ".tar.gz"))
208 (sha256
209 (base32
210 "178dc279f5j894qvp96dzz7c0jpryqlcqw5g0dc9yaxg9kgw1lqm"))))
211 (build-system gnu-build-system)
212 ;; TODO: We should package a small socks4/5 library/server to configure
213 ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
214 ;; is too big.
215 (arguments
216 `(#:tests? #f
217 #:configure-flags (list
218 "--enable-ipv6"
219 "--with-emacs-meta-keys"
220 (string-append "--with-openssl="
221 (assoc-ref %build-inputs "openssl")))
222 #:phases
223 (modify-phases %standard-phases
224 (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
225 (lambda* (#:key inputs #:allow-other-keys)
226 (substitute* "bsdinstall"
227 (("/bin/strip") "strip")
228 (("/bin/cp") "cp")
229 (("/bin/chmod") "chmod")
230 (("/etc/chown") "chown")
231 (("/bin/chgrp") "chgrp")
232 (("/bin/mkdir") "mkdir")
233 (("/bin/rm") "rm")
234 (("/bin/mv") "mv")))))))
235 (inputs
236 `(("ncurses" ,ncurses)
237 ("openssl" ,openssl)))
238 (native-inputs
239 `(("pkg-config" ,pkg-config)
240 ("perl" ,perl)))
241 (home-page "http://www.eterna.com.au/ircii/")
242 (synopsis "Terminal-based IRC and ICB client")
243 (description
244 "ircII is a terminal based IRC and ICB client for UNIX systems.")
245 (license license:bsd-3)))
246
247 (define-public ii
248 (package
249 (name "ii")
250 (version "1.7")
251 (source (origin
252 (method url-fetch)
253 (uri (string-append "http://dl.suckless.org/tools/"
254 name "-" version ".tar.gz"))
255 (sha256
256 (base32
257 "176cqwnn6h7w4kbfd66hzqa243l26pqp2b06bii0nmnm0rkaqwis"))))
258 (build-system gnu-build-system)
259 (arguments
260 `(#:tests? #f ; no tests
261 #:make-flags (list (string-append "PREFIX=" %output)
262 "CC=gcc")
263 #:phases
264 (modify-phases %standard-phases
265 (delete 'configure)))) ; no configure
266 (home-page "http://tools.suckless.org/ii/")
267 (synopsis "FIFO and file system based IRC client")
268 (description
269 "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
270 (license license:expat)))
271
272 (define-public sic
273 (package
274 (name "sic")
275 (version "1.2")
276 (source (origin
277 (method url-fetch)
278 (uri (string-append "http://dl.suckless.org/tools/"
279 name "-" version ".tar.gz"))
280 (sha256
281 (base32
282 "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
283 (build-system gnu-build-system)
284 (arguments
285 `(#:tests? #f ; no tests
286 #:make-flags (list "CC=gcc"
287 (string-append "PREFIX=" %output))
288 #:phases
289 (modify-phases %standard-phases
290 (delete 'configure)))) ; no configure
291 (home-page "http://tools.suckless.org/sic/")
292 (synopsis "Simple IRC client")
293 (description
294 "sic is a simple IRC client, even more minimalistic than ii.")
295 (license license:expat)))
296
297 (define-public limnoria
298 (package
299 (name "limnoria")
300 (version "2016.08.07")
301 (source
302 (origin
303 (method url-fetch)
304 (uri (pypi-uri "limnoria" version))
305 (sha256
306 (base32
307 "0w1d98hfhn4iqrczam7zahhqsvxa79n3xfcrm4jwkg5lba4f9ccm"))))
308 (build-system python-build-system)
309 (inputs
310 `(("python-pytz" ,python-pytz)
311 ("python-chardet" ,python-chardet)
312 ("python-dateutil" ,python-dateutil)
313 ("python-gnupg" ,python-gnupg)
314 ("python-feedparser" ,python-feedparser)
315 ("python-sqlalchemy" ,python-sqlalchemy)
316 ("python-socksipy-branch" ,python-socksipy-branch)
317 ("python-ecdsa" ,python-ecdsa)))
318 (native-inputs
319 `(("python-mock" ,python-mock)))
320 ;; Despite the existence of a test folder there is no test phase.
321 ;; We need to package https://github.com/ProgVal/irctest and write
322 ;; our own testphase.
323 (arguments
324 `(#:tests? #f))
325 (home-page "https://github.com/ProgVal/Limnoria")
326 (synopsis "Modified version of Supybot (an IRC bot and framework)")
327 (description
328 "Modified version of Supybot with Python 3 and IRCv3 support,
329 embedded web server, translations (fr, fi, it, hu, de), and many
330 other enhancements and bug fixes.")
331 (license license:bsd-3)))