gnu: Add java-sonatype-forge-parent-pom-5.
[jackhill/guix/guix.git] / gnu / packages / maven-parent-pom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages maven-parent-pom)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix git-download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system ant)
25 #:use-module (gnu packages java))
26
27 (define (make-apache-parent-pom version hash)
28 (hidden-package
29 (package
30 (name "apache-parent-pom")
31 (version version)
32 (source (origin
33 (method git-fetch)
34 (uri (git-reference
35 (url "https://github.com/apache/maven-apache-parent")
36 (commit (string-append "apache-" version))))
37 (file-name (git-file-name name version))
38 (sha256 (base32 hash))))
39 (build-system ant-build-system)
40 (arguments
41 `(#:tests? #f
42 #:phases
43 (modify-phases %standard-phases
44 (delete 'configure)
45 (delete 'build)
46 (replace 'install
47 (install-pom-file "pom.xml")))))
48 (home-page "https://apache.org/")
49 (synopsis "Apache parent pom")
50 (description "This package contains the Apache parent POM.")
51 (license license:asl2.0))))
52
53 (define-public apache-parent-pom-6
54 (make-apache-parent-pom
55 "6" "1bq0ma2ya2cnp2icd4l20sv6y7zxqr9sa35wzv1s49nqsrm38kw3"))
56
57 (define-public apache-parent-pom-11
58 (make-apache-parent-pom
59 "11" "0m1a4db8s6y8f4vvm9bx7zx7lixcvaah064560nbja7na3xz6lls"))
60
61 (define-public apache-parent-pom-13
62 (make-apache-parent-pom
63 "13" "1cfxaz1jy8fbn06sb648qpiq23swpbj3kb5ya7f9g9jmya5fy09z"))
64
65 (define-public apache-parent-pom-16
66 (make-apache-parent-pom
67 "16" "1y5b0dlc72ijcqfffdbh0k75qwaddy5qw725v9pzhrzqkpaa51xb"))
68
69 (define-public apache-parent-pom-17
70 (make-apache-parent-pom
71 "17" "06hj5d6rdkmwl24k2rvzj8plq8x1ncsbjck4w3awz1hp9gngg4y5"))
72
73 (define-public apache-parent-pom-18
74 (make-apache-parent-pom
75 "18" "1il97vpdmv5k2gnyinj45q00f7f4w9hcb588digwfid5bskddnyy"))
76
77 (define-public apache-parent-pom-19
78 (make-apache-parent-pom
79 "19" "02drnwv2qqk1dmxbmmrk0bi1iil5cal9l47w53ascpbjg6242mp1"))
80
81 (define-public apache-parent-pom-21
82 (make-apache-parent-pom
83 "21" "0clcbrq1b2b8sbvlqddyw2dg5niq25dhdma9sk4b0i30hqaipx96"))
84
85 (define (make-apache-commons-parent-pom version hash parent)
86 (hidden-package
87 (package
88 (name "apache-commons-parent-pom")
89 (version version)
90 (source (origin
91 (method git-fetch)
92 (uri (git-reference
93 (url "https://github.com/apache/commons-parent")
94 (commit (string-append "commons-parent-" version))))
95 (file-name (git-file-name name version))
96 (sha256 (base32 hash))))
97 (build-system ant-build-system)
98 (arguments
99 `(#:tests? #f
100 #:phases
101 (modify-phases %standard-phases
102 (delete 'configure)
103 (delete 'build)
104 (replace 'install
105 (install-pom-file "pom.xml")))))
106 (propagated-inputs
107 (if parent
108 `(("parent" ,parent))
109 '()))
110 (home-page "https://maven.apache.org/")
111 (synopsis "Apache Commons parent pom")
112 (description "This package contains the Apache Commons parent POM.")
113 (license license:asl2.0))))
114
115 (define-public apache-commons-parent-pom-39
116 (make-apache-commons-parent-pom
117 "39" "0mjx48a55ik1h4hsxhifkli1flvkp6d05ab14p4al0fc6rhdxi46"
118 apache-parent-pom-16))
119
120 (define-public apache-commons-parent-pom-41
121 (make-apache-commons-parent-pom
122 "41" "1k184amdqdx62bb2k0m9v93zzx768qcyam5dvdgksqc1aaqhadlb"
123 apache-parent-pom-18))
124
125 (define-public apache-commons-parent-pom-48
126 (make-apache-commons-parent-pom
127 "48" "0dk8qp7swbh4y1q7q34y14yhigzl5yz0ixa8jhhhq91yc2q570iq"
128 apache-parent-pom-21))
129
130 (define-public apache-commons-parent-pom-50
131 (make-apache-commons-parent-pom
132 "50" "0ki8px35dan51ashblpw6rdl27c2fq62slazhslhq3lr4fwlpvxs"
133 apache-parent-pom-21))
134
135 (define-public java-weld-parent-pom
136 (hidden-package
137 (package
138 (name "java-weld-parent-pom")
139 (version "36")
140 (source (origin
141 (method git-fetch)
142 (uri (git-reference
143 (url "https://github.com/weld/parent")
144 (commit version)))
145 (file-name (git-file-name name version))
146 (sha256
147 (base32
148 "0rbvizcsma456mw9fvp4dj9cljh97nswvhi04xhczi38j5bgal0m"))))
149 (build-system ant-build-system)
150 (arguments
151 `(#:tests? #f
152 #:phases
153 (modify-phases %standard-phases
154 (delete 'build)
155 (replace 'install
156 (install-pom-file "pom.xml")))))
157 (home-page "https://github.com/weld/parent")
158 (synopsis "Pom parent file for weld projects")
159 (description "This package contains the parent Maven Pom for weld projects.")
160 (license license:asl2.0))))
161
162 (define (make-java-sonatype-forge-parent-pom version hash)
163 (hidden-package
164 (package
165 (name "java-sonatype-forge-parent-pom")
166 (version version)
167 (source (origin
168 (method git-fetch)
169 (uri (git-reference
170 (url "https://github.com/sonatype/oss-parents")
171 (commit (string-append "forge-parent-" version))))
172 (file-name (git-file-name name version))
173 (sha256 (base32 hash))))
174 (build-system ant-build-system)
175 (arguments
176 `(#:tests? #f
177 #:phases
178 (modify-phases %standard-phases
179 (delete 'build)
180 (delete 'configure)
181 (replace 'install
182 (install-pom-file "pom.xml")))))
183 (home-page "https://github.com/sonatype/oss-parents")
184 (synopsis "Sonatype forge parent pom")
185 (description "This package contains a single pom.xml file that is used by
186 other projects as their parent pom.")
187 (license license:asl2.0))))
188
189 (define-public java-sonatype-forge-parent-pom-4
190 (make-java-sonatype-forge-parent-pom
191 "4" "1gip239ar20qzy6yf37r6ks54bl7gqi1v49p65manrz84cmad0dh"))
192
193 (define-public java-sonatype-forge-parent-pom-5
194 (make-java-sonatype-forge-parent-pom
195 "5" "0pr60wyjmaml4flmcij6l94b72ryx5gsiiasiwvcvrz9b2fkb3cd"))