build-system: asdf: Switch from bundles to regular compilation.
[jackhill/guix/guix.git] / gnu / packages / patches / sbcl-graph-asdf-definitions.patch
1 commit 52ebece1243ae6900e414b6248b5145a28348eef
2 Author: Guillaume Le Vaillant <glv@posteo.net>
3 Date: Fri Oct 18 15:41:23 2019 +0200
4
5 Use basic ASDF system definitions instead of package-inferred-system
6
7 diff --git a/graph.asd b/graph.asd
8 index 193b6e3..56afc8f 100644
9 --- a/graph.asd
10 +++ b/graph.asd
11 @@ -3,12 +3,10 @@
12 :version "0.0.0"
13 :author ("Eric Schulte <schulte.eric@gmail.com>" "Thomas Dye")
14 :licence "GPL V3"
15 - :class :package-inferred-system
16 - :defsystem-depends-on (:asdf-package-system)
17 + :in-order-to ((test-op (test-op graph-test)))
18 :depends-on (alexandria
19 metabang-bind
20 named-readtables
21 curry-compose-reader-macros
22 - graph/graph))
23 -
24 -(register-system-packages "femlisp-matlisp" '(:fl.matlisp))
25 + cl-heap)
26 + :components ((:file "graph")))
27 diff --git a/graph-dot.asd b/graph-dot.asd
28 new file mode 100644
29 index 0000000..12aec7e
30 --- /dev/null
31 +++ b/graph-dot.asd
32 @@ -0,0 +1,8 @@
33 +(defsystem :graph-dot
34 + :depends-on (alexandria
35 + metabang-bind
36 + named-readtables
37 + curry-compose-reader-macros
38 + cl-ppcre
39 + graph)
40 + :components ((:file "dot")))
41 diff --git a/graph-json.asd b/graph-json.asd
42 new file mode 100644
43 index 0000000..e7d091f
44 --- /dev/null
45 +++ b/graph-json.asd
46 @@ -0,0 +1,8 @@
47 +(defsystem :graph-json
48 + :depends-on (alexandria
49 + metabang-bind
50 + named-readtables
51 + curry-compose-reader-macros
52 + yason
53 + graph)
54 + :components ((:file "json")))
55 diff --git a/graph-test.asd b/graph-test.asd
56 new file mode 100644
57 index 0000000..1e811e1
58 --- /dev/null
59 +++ b/graph-test.asd
60 @@ -0,0 +1,10 @@
61 +(defsystem :graph-test
62 + :depends-on (alexandria
63 + metabang-bind
64 + named-readtables
65 + curry-compose-reader-macros
66 + graph
67 + stefil)
68 + :perform (test-op (o s)
69 + (uiop:symbol-call :graph/test 'test))
70 + :components ((:file "test")))