gnu: python-unidecode: Fix typo in description.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde)
21 #:use-module (guix build-system cmake)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages apr)
27 #:use-module (gnu packages boost)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages documentation)
30 #:use-module (gnu packages gl)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages kde-frameworks)
33 #:use-module (gnu packages llvm)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages tls)
36 #:use-module (gnu packages qt)
37 #:use-module (gnu packages version-control))
38
39 (define-public kdevelop
40 (package
41 (name "kdevelop")
42 (version "5.1.2")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "mirror://kde/stable/kdevelop"
47 "/" version "/src/kdevelop-"
48 version ".tar.xz"))
49 (sha256
50 (base32
51 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
52 (build-system cmake-build-system)
53 (native-inputs
54 `(("extra-cmake-modules" ,extra-cmake-modules)
55 ("pkg-config" ,pkg-config)
56 ("qttools" ,qttools)))
57 (inputs
58 `(("kdevplatform" ,kdevplatform)
59 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
60 ("qtbase" ,qtbase)
61 ("qtdeclarative" ,qtdeclarative)
62 ("qtquickcontrols" ,qtquickcontrols)
63 ("qtwebkit" ,qtwebkit)
64 ("karchive" ,karchive)
65 ("kcmutils" ,kcmutils)
66 ("kconfig" ,kconfig)
67 ("kdeclarative" ,kdeclarative)
68 ("kdoctools" ,kdoctools)
69 ("kguiaddons" ,kguiaddons)
70 ("ki18n" ,ki18n)
71 ("kio" ,kio)
72 ("kiconthemes" ,kiconthemes)
73 ("kitemmodels" ,kitemmodels)
74 ("kitemviews" ,kitemviews)
75 ("kjobwidgets" ,kjobwidgets)
76 ("knotifyconfig" ,knotifyconfig)
77 ("knotifications" ,knotifications)
78 ("kparts" ,kparts)
79 ("kcrash" ,kcrash)
80 ("knewstuff" ,knewstuff)
81 ("krunner" ,krunner)
82 ("kxmlgui" ,kxmlgui)
83 ("libksysguard" ,libksysguard)
84 ("threadweaver" ,threadweaver)
85 ("ktexteditor" ,ktexteditor)
86 ("kwindowsystem" ,kwindowsystem)
87 ("plasma" ,plasma-framework)
88 ("grantlee" ,grantlee)
89 ("libepoxy" ,libepoxy)
90 ("clang" ,clang)
91 ("shared-mime-info" ,shared-mime-info)))
92 (arguments
93 `(#:phases
94 (modify-phases %standard-phases
95 (delete 'check) ;; there are some issues with the test suite
96 (add-after 'install 'wrap-executable
97 (lambda* (#:key inputs outputs #:allow-other-keys)
98 (let* ((out (assoc-ref outputs "out"))
99 (kdevplatform (assoc-ref inputs "kdevplatform"))
100 (kio (assoc-ref inputs "kio"))
101 (kcmutils (assoc-ref inputs "kcmutils"))
102 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
103 (qtbase (assoc-ref inputs "qtbase"))
104 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
105 (profile "$HOME/.guix-profile")
106 (qml "/qml"))
107 (wrap-program (string-append out "/bin/kdevelop")
108 `("XDG_DATA_DIRS" ":" prefix
109 ,(map (lambda (s) (string-append s "/share"))
110 (list profile out kdevplatform kcmutils)))
111 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
112 (,(string-append qtbase "/plugins/platforms")))
113 `("QT_PLUGIN_PATH" ":" prefix
114 ,(map (lambda (s) (string-append s "/lib/plugins"))
115 (list profile out kdevplatform kio)))
116 `("QML2_IMPORT_PATH" ":" prefix
117 (,(string-append qtquickcontrols qml)
118 ,(string-append qtdeclarative qml))))))))))
119 (home-page "https://kdevelop.org")
120 (synopsis "IDE for C, C++, Python, Javascript and PHP")
121 (description "The KDevelop IDE provides semantic syntax highlighting, as
122 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
123 JavaScript, Python and PHP. It also integrates with a debugger, different
124 build systems (CMake, QMake, custom Makefiles) and version control
125 software (Git, Subversion, Mercurial, CVS and Bazaar).")
126 (license license:lgpl2.1+)))
127
128 (define-public kdevelop-pg-qt
129 (package
130 (name "kdevelop-pg-qt")
131 (version "2.0.0")
132 (source
133 (origin
134 (method url-fetch)
135 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
136 version ".tar.gz"))
137 (file-name (string-append name "-" version ".tar.gz"))
138 (sha256
139 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
140 (native-inputs
141 `(("extra-cmake-modules" ,extra-cmake-modules)))
142 (inputs
143 `(("qtbase" ,qtbase)))
144 (build-system cmake-build-system)
145 (home-page "https://kde.org")
146 (synopsis "Parser generator library for KDevplatform")
147 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
148 for some KDevelop language plugins (Ruby, PHP, CSS...).")
149 (license license:lgpl2.0+)))
150
151 (define-public kdevplatform
152 (package
153 (name "kdevplatform")
154 (version "5.1.2")
155 (source (origin
156 (method url-fetch)
157 (uri (string-append "mirror://kde/stable/kdevelop"
158 "/" version "/src/kdevplatform-"
159 version ".tar.xz"))
160 (sha256
161 (base32
162 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
163 (build-system cmake-build-system)
164 (native-inputs
165 `(("extra-cmake-modules" ,extra-cmake-modules)
166 ("pkg-config" ,pkg-config)))
167 (inputs
168 `(("apr" ,apr)
169 ("apr-util" ,apr-util)
170 ("boost" ,boost)
171 ("karchive" ,karchive)
172 ("kconfigwidgets" ,kconfigwidgets)
173 ("kcmutils" ,kcmutils)
174 ("kiconthemes" ,kiconthemes)
175 ("kdeclarative" ,kdeclarative)
176 ("kdoctools" ,kdoctools)
177 ("kguiaddons" ,kguiaddons)
178 ("kinit" ,kinit)
179 ("kitemmodels" ,kitemmodels)
180 ("knewstuff" ,knewstuff)
181 ("knotifications" ,knotifications)
182 ("knotifyconfig" ,knotifyconfig)
183 ("kwindowsystem" ,kwindowsystem)
184 ("kio" ,kio)
185 ("ki18n" ,ki18n)
186 ("kparts" ,kparts)
187 ("kservice" ,kservice)
188 ("grantlee" ,grantlee)
189 ("libkomparediff2" ,libkomparediff2)
190 ("sonnet" ,sonnet)
191 ("threadweaver" ,threadweaver)
192 ("ktexteditor" ,ktexteditor)
193 ("qtbase" ,qtbase)
194 ("qtdeclarative" ,qtdeclarative)
195 ("qtscript" ,qtscript)
196 ("qtwebkit" ,qtwebkit)
197 ("qtx11extras" ,qtx11extras)
198 ("plasma" ,plasma-framework)
199 ("subversion" ,subversion)
200 ("zlib" ,zlib)))
201 (arguments
202 `(#:phases
203 (modify-phases %standard-phases
204 (delete 'check)
205 (add-after 'install 'check ;; add-after 'install
206 (lambda* (#:key outputs #:allow-other-keys)
207 (let ((out (assoc-ref outputs "out")))
208 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
209 (setenv "QT_PLUGIN_PATH"
210 (string-append out "/lib/plugins:"
211 (getenv "QT_PLUGIN_PATH")))
212 (setenv "XDG_DATA_DIRS"
213 (string-append out "/share:"
214 (getenv "XDG_DATA_DIRS")))
215 (zero?
216 (system* "ctest" "-R" ;; almost all tests require a display
217 "filteringstrategy|kdevvarlengtharray|kdevhash"))))))))
218 (home-page "https://github.com/KDE/kdevplatform")
219 (synopsis "Framework to build integrated development environments (IDEs)")
220 (description "KDevPlatform is the basis of KDevelop and contains some
221 plugins, as well as code to create plugins, or complete applications.")
222 (license license:gpl3+)))
223
224 (define-public libkomparediff2
225 (package
226 (name "libkomparediff2")
227 (version "16.08.2")
228 (source
229 (origin
230 (method url-fetch)
231 (uri (string-append "https://github.com/KDE/libkomparediff2/archive/v"
232 version ".tar.gz"))
233 (file-name (string-append name "-" version ".tar.gz"))
234 (sha256
235 (base32
236 "1lafifrwfxvn0jwhz67kwv7m38lm4syips3fq77rwcvfhmkiijmh"))))
237 (native-inputs
238 `(("extra-cmake-modules" ,extra-cmake-modules)
239 ("pkg-config" ,pkg-config)))
240 (inputs
241 `(("kcodecs" ,kcodecs)
242 ("kconfig" ,kconfig)
243 ("kcoreaddons" ,kcoreaddons)
244 ("ki18n" ,ki18n)
245 ("kio" ,kio)
246 ("kxmlgui" ,kxmlgui)
247 ("qtbase" ,qtbase)))
248 (build-system cmake-build-system)
249 (home-page "https://kde.org")
250 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
251 (description "Libkomparediff2 is a library to work with diffs and patches,
252 used in KDE development tools Kompare and KDevelop.")
253
254 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
255 ;; source archive
256 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
257
258 (define-public libksysguard
259 (package
260 (name "libksysguard")
261 (version "5.10.4")
262 (source
263 (origin
264 (method url-fetch)
265 (uri (string-append "mirror://kde//stable/plasma/" version
266 "/libksysguard-" version ".tar.xz"))
267 (sha256
268 (base32
269 "01w0laywva0p0ar2lvr1k5000bhjikjfxsb4f6p30qswrchrmrh3"))))
270 (native-inputs
271 `(("extra-cmake-modules" ,extra-cmake-modules)
272 ("pkg-config" ,pkg-config)))
273 (inputs
274 `(("kconfigwidgets" ,kconfigwidgets)
275 ("kiconthemes" ,kiconthemes)
276 ("kwindowsystem" ,kwindowsystem)
277 ("ki18n" ,ki18n)
278 ("kauth" ,kauth)
279 ("kcompletion" ,kcompletion)
280 ("kconfig" ,kconfig)
281 ("kcoreaddons" ,kcoreaddons)
282 ("kwidgetsaddons" ,kwidgetsaddons)
283 ("kservice" ,kservice)
284 ("qtbase" ,qtbase)
285 ("qtscript" ,qtscript)
286 ("qtwebkit" ,qtwebkit)
287 ("qtx11extras" ,qtx11extras)
288 ("plasma" ,plasma-framework)
289 ("zlib" ,zlib)))
290 (build-system cmake-build-system)
291 (arguments
292 `(#:configure-flags
293 `(,(string-append "-DKDE_INSTALL_DATADIR="
294 (assoc-ref %outputs "out") "/share"))
295 #:phases
296 (modify-phases %standard-phases
297 (add-before 'configure 'patch-cmakelists
298 (lambda _
299 ;; TODO: Verify: This should no longer be necessary, since
300 ;; KF5AuthConfig.cmake.in contains this already.
301 (substitute* "processcore/CMakeLists.txt"
302 (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
303 (add-before 'check 'check-setup
304 (lambda _
305 ;; make Qt render "offscreen", required for tests
306 (setenv "QT_QPA_PLATFORM" "offscreen")))
307 (replace 'check
308 (lambda _
309 ;; TODO: Fix this failing test-case
310 (zero? (system* "ctest" "-E" "processtest")))))))
311 (home-page "https://www.kde.org/info/plasma-5.10.4.php")
312 (synopsis "Network enabled task and system monitoring")
313 (description "KSysGuard can obtain information on system load and
314 manage running processes. It obtains this information by interacting
315 with a ksysguardd daemon, which may also run on a remote system.")
316 (license license:gpl3+)))
317
318 (define-public qca
319 (package
320 (name "qca")
321 (version "2.1.3")
322 (source
323 (origin
324 (method url-fetch)
325 (uri (string-append "http://download.kde.org/stable/qca/" version
326 "/src/qca-" version ".tar.xz"))
327 (sha256
328 (base32
329 "0lz3n652z208daxypdcxiybl0a9fnn6ida0q7fh5f42269mdhgq0"))))
330 (build-system cmake-build-system)
331 (native-inputs
332 `(("pkg-config" ,pkg-config)))
333 (inputs
334 `(("openssl" ,openssl)
335 ("qtbase" ,qtbase)))
336 (home-page "https://userbase.kde.org/QCA")
337 (synopsis "Libraries for the Qt Cryptographic Architecture")
338 (description "The Qt Cryptographic Architecture (QCA) provides a
339 straightforward and cross-platform API for a range of cryptographic features,
340 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
341 cards.")
342 (license license:lgpl2.1)))
343
344 (define-public snorenotify
345 (package
346 (name "snorenotify")
347 (version "0.7.0")
348 (source
349 (origin
350 (method url-fetch)
351 (uri (string-append "http://download.kde.org/stable/snorenotify/"
352 version "/src/snorenotify-" version ".tar.xz"))
353 (sha256
354 (base32
355 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
356 (build-system cmake-build-system)
357 (arguments
358 `(#:tests? #f)) ; both tests fail, require display
359 (inputs
360 `(("extra-cmake-modules" ,extra-cmake-modules)
361 ("qtbase" ,qtbase)
362 ("qttools" ,qttools)))
363 (home-page "https://techbase.kde.org/Projects/Snorenotify")
364 (synopsis "Qt notification framework")
365 (description "Snorenotify is a multi platform Qt notification framework.
366 Using a plugin system it is possible to create notifications with many
367 different notification systems.")
368 (license license:lgpl3)))