gnu: Add libcdr.
[jackhill/guix/guix.git] / gnu / packages / libreoffice.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libreoffice)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:select (lgpl2.1+ mpl2.0))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages boost)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages doxygen)
29 #:use-module (gnu packages ghostscript)
30 #:use-module (gnu packages gperf)
31 #:use-module (gnu packages icu4c)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages python)
35 #:use-module (gnu packages xml))
36
37 (define-public ixion
38 (package
39 (name "ixion")
40 (version "0.9.1")
41 (source
42 (origin
43 (method url-fetch)
44 (uri (string-append "http://kohei.us/files/ixion/src/libixion-"
45 version ".tar.xz"))
46 (sha256 (base32
47 "18g3nk29ljiqbyi0ml49j2x3f3xrqckdm9i66sw5fxnj7hb5rqvp"))))
48 (build-system gnu-build-system)
49 (native-inputs
50 `(("pkg-config" ,pkg-config)))
51 (inputs
52 `(("mdds" ,mdds)
53 ("python" ,python-2))) ; looks for python.pc, not python3.pc
54 (home-page "https://gitlab.com/ixion/ixion")
55 (synopsis "General purpose formula parser and interpreter")
56 (description "Ixion is a library for calculating the results of formula
57 expressions stored in multiple named targets, or \"cells\". The cells can
58 be referenced from each other, and the library takes care of resolving
59 their dependencies automatically upon calculation.")
60 (license mpl2.0)))
61
62 (define-public orcus
63 (package
64 (name "orcus")
65 (version "0.7.1")
66 (source
67 (origin
68 (method url-fetch)
69 (uri (string-append "http://kohei.us/files/" name "/src/lib"
70 name "-" version ".tar.xz"))
71 (sha256 (base32
72 "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
73 (build-system gnu-build-system)
74 (native-inputs
75 `(("pkg-config" ,pkg-config)))
76 (inputs
77 `(("ixion" ,ixion)
78 ("mdds" ,mdds)
79 ("zlib" ,zlib)))
80 (home-page "https://gitlab.com/orcus/orcus")
81 (synopsis "File import filter library for spreadsheet documents")
82 (description "Orcus is a library that provides a collection of standalone
83 file processing filters. It is currently focused on providing filters for
84 spreadsheet documents. The library includes import filters for
85 Microsoft Excel 2007 XML, Microsoft Excel 2003 XML, Open Document Spreadsheet,
86 Plain Text, Gnumeric XML, Generic XML. It also includes low-level parsers for
87 CSV, CSS and XML.")
88 (license mpl2.0)))
89
90 (define-public librevenge
91 (package
92 (name "librevenge")
93 (version "0.0.2")
94 (source
95 (origin
96 (method url-fetch)
97 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
98 version ".tar.xz"))
99 (sha256 (base32
100 "03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
101 (build-system gnu-build-system)
102 (native-inputs
103 `(("boost" ,boost)
104 ("cppunit" ,cppunit)
105 ("doxygen" ,doxygen)
106 ("pkg-config" ,pkg-config)))
107 (inputs
108 `(("zlib" ,zlib)))
109 (arguments
110 ;; avoid triggering configure errors by simple inclusion of boost headers
111 `(#:configure-flags '("--disable-werror")))
112 (home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
113 (synopsis "Document importer for office suites")
114 (description "Librevenge is a base library for writing document import
115 filters. It has interfaces for text documents, vector graphics,
116 spreadsheets and presentations.")
117 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
118
119 (define-public libwpd
120 (package
121 (name "libwpd")
122 (version "0.10.0")
123 (source
124 (origin
125 (method url-fetch)
126 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
127 version ".tar.xz"))
128 (sha256 (base32
129 "0b6krzr6kxzm89g6bapn805kdayq70hn16n5b5wfs2lwrf0ag2wx"))))
130 (build-system gnu-build-system)
131 (native-inputs
132 `(("doxygen" ,doxygen)
133 ("pkg-config" ,pkg-config)))
134 (inputs
135 `(("librevenge" ,librevenge)
136 ("zlib" ,zlib)))
137 (home-page "http://libwpd.sourceforge.net/")
138 (synopsis "Library for importing WordPerfect documents")
139 (description "Libwpd is a C++ library designed to help process
140 WordPerfect documents. It is most commonly used to import such documents
141 into other word processors.")
142 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
143
144 (define-public libe-book
145 (package
146 (name "libe-book")
147 (version "0.1.2")
148 (source
149 (origin
150 (method url-fetch)
151 (uri (string-append "mirror://sourceforge/libebook/libe-book-"
152 version "/libe-book-" version ".tar.xz"))
153 (sha256
154 (base32
155 "1v48pd32r2pfysr3a3igc4ivcf6vvb26jq4pdkcnq75p70alp2bz"))))
156 (build-system gnu-build-system)
157 (native-inputs
158 `(("cppunit" ,cppunit)
159 ("gperf" ,gperf)
160 ("pkg-config" ,pkg-config)))
161 (inputs `(("boost" ,boost)
162 ("icu4c" ,icu4c)
163 ("librevenge" ,librevenge)
164 ("libxml2" ,libxml2)))
165 (arguments
166 ;; avoid triggering configure errors by simple inclusion of boost headers
167 `(#:configure-flags '("--disable-werror")))
168 (home-page "http://libebook.sourceforge.net")
169 (synopsis "Library for import of reflowable e-book formats")
170 (description "Libe-book is a library and a set of tools for reading and
171 converting various reflowable e-book formats. Currently supported are:
172 Broad Band eBook, eReader .pdb, FictionBook v. 2 (including zipped files),
173 PalmDoc Ebook, Plucker .pdb, QiOO (mobile format, for java-enabled
174 cellphones), TCR (simple compressed text format), TealDoc, zTXT,
175 ZVR (simple compressed text format).")
176 (license mpl2.0)))
177
178 (define-public libwpg
179 (package
180 (name "libwpg")
181 (version "0.3.0")
182 (source
183 (origin
184 (method url-fetch)
185 (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
186 version ".tar.xz"))
187 (sha256 (base32
188 "097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
189 (build-system gnu-build-system)
190 (native-inputs
191 `(("doxygen" ,doxygen)
192 ("pkg-config" ,pkg-config)))
193 (inputs
194 `(("librevenge" ,librevenge)
195 ("libwpd" ,libwpd)
196 ("perl" ,perl)
197 ("zlib" ,zlib)))
198 (home-page "http://libwpg.sourceforge.net/")
199 (synopsis "Library and tools for the WordPerfect Graphics format")
200 (description "The libwpg project provides a library and tools for
201 working with graphics in the WPG (WordPerfect Graphics) format.")
202 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
203
204 (define-public libabw
205 (package
206 (name "libabw")
207 (version "0.1.1")
208 (source
209 (origin
210 (method url-fetch)
211 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
212 name "-" version ".tar.xz"))
213 (sha256 (base32
214 "0zi1zj4fpxgpglbbb5n1kg3dmhqq5rpf46lli89r5daavp19iing"))))
215 (build-system gnu-build-system)
216 (native-inputs
217 `(("doxygen" ,doxygen)
218 ("gperf" ,gperf)
219 ("perl" ,perl)
220 ("pkg-config" ,pkg-config)))
221 (inputs
222 `(("boost" ,boost)
223 ("librevenge" ,librevenge)
224 ("libxml2" ,libxml2)))
225 (arguments
226 ;; avoid triggering configure errors by simple inclusion of boost headers
227 `(#:configure-flags '("--disable-werror")))
228 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libabw")
229 (synopsis "Library for parsing the AbiWord format")
230 (description "Libabw is a library that parses the file format of
231 AbiWord documents.")
232 (license mpl2.0)))
233
234 (define-public libcdr
235 (package
236 (name "libcdr")
237 (version "0.1.1")
238 (source
239 (origin
240 (method url-fetch)
241 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
242 name "-" version ".tar.xz"))
243 (sha256 (base32
244 "07yzb1yr5kzv0binzj5swz3zzay2gw3xb0fbkc2zwdssgrkf19nh"))))
245 (build-system gnu-build-system)
246 (native-inputs
247 `(("doxygen" ,doxygen)
248 ("pkg-config" ,pkg-config)))
249 (inputs
250 `(("boost" ,boost)
251 ("icu4c" ,icu4c)
252 ("lcms" ,lcms)
253 ("librevenge" ,librevenge)
254 ("zlib" ,zlib)))
255 (arguments
256 ;; avoid triggering a build failure due to warnings
257 `(#:configure-flags '("--disable-werror")))
258 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libcdr")
259 (synopsis "Library for parsing the CorelDRAW format")
260 (description "Libcdr is a library that parses the file format of
261 CorelDRAW documents of all versions.")
262 (license mpl2.0)))